Página 1 de 2 12 ÚltimoÚltimo
  1. #1
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane

    Instalar Leopard en ASUS P5K-VM

    Hola, he leido bastante sobre la instalacion del leopard, pero no encuetro a nadie con el mismo problema que yo.

    A ver, la version que tengo es la 10.5.2 leo4All, y mi makina cumple los requisitos, la placa es Asus P5K-VM, micro intel core duo 2.67ghz, 4 gb ram ddr2 667, disco duro sAta 2 de 320gb en este me da error cuando a la instalacion le queda un 1%. y en un ide me da error cuando queda 2%, he leido el manual MAc guia que anda por este foro, y otros mas, pero nada siempre me da el mismo error.



    Lo pongo con el kernel vanilla 9.0.2 y con y sin drivers e probado pero siempre igual

    Alguno me puede ayudar??

    Muchas gracias

  2. #2
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    "... la versión que tengo es la 10.5.2 leo4All, y mi mákina cumple los requisitos..."

    ¿Qué requisitos? ¿Dónde están escritos? Que estamos instalando un sistema operativo hackeado en un ordenador para el que no está diseñado... Los únicos que cumplen los requisitos son los Mac "de verdad".

    Lo que hay son reglas generales acerca del hardware que suele dar mejores resultados pero si lees más por los foros verás que a veces la misma placa base se comporta de manera diferente en 2 usuarios distintos. Habría que tener idénticas placa base, gráfica, fuente de alimentación y caja para poder decir que lo que a uno le va bien le irá al otro con seguridad.

    En tu caso hay que saber qué chipset usa la placa base, tanto el norte como el sur. Por ejemplo, en mi caso el puente norte es G33 y el puente sur es ICH9R. ¿Y en el tuyo?.

  3. #3
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    Por lo ke me dices es mas complicado de lo que parece. Bueno el chipset que lleva es parecido al tuyo G33 / ICH9.

    Necesitas algun dato mas ?

    Saludos

  4. #4
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Tienes G33 y ICH9 así que por ese lado es compatible. La gráfica integrada no va a funcionar bien. El audio debería funcionar con salida analógica (no entrada de micro) si eliges el driver adecuado en la instalación (Alc883). La red no sé si funcionará sin retocar el archivo kext correspondiente.

    Deberías probar otra distro, por ejemplo Kalyway 10.5.2. En mi caso se instala mejor que Leo4all.

    ¿Formateas el destino de OSX como Mac OS Plus con registro?

    Todos los detalles comentados más arriba ya nos los tenías que haber dicho tú al solicitar ayuda.

  5. #5
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    lo que estoy probando ahora mismo es a darle un formateo completo el de escribir ceros, y he modificado algunas cosas de la bios como activar AHCI. He quitado los demas HDD y he dejado solo el de instalacion a ver que tal

  6. #6
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    ok, gracias voy a probar esta ke me dices Kalyway 10.5.2, si formateo con registro y selecciono MBR, creo que todos los pasos los selecciono bien, pero obiamente alguno me falta.
    Gracias por todo

  7. #7
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    No conozco tu placa pero estas serían las ideas generales:

    - no usar más de 2 GB de RAM (con 4 GB hay errores para instalar o arrancar Leopard)
    - usar sólo dispositivos SATA (desactivando IDE en la BIOS)
    - el modo SATA en la BIOS ha de ser Enhanced
    - yo no usaría AHCI pero puedes probar con y sin AHCI a ver qué tal
    - al instalar Leopard, formatear el disco como HFS+ (Mac OS Plus con registro)
    - el mapa de particiones puede ser MBR o CUID, ambos deberían funcionar pero si ves que con uno da problemas pruebas el otro
    - elige sólo lo imprescindible en la instalación (audio Alc883...)
    - averigua qué chip Ethernet llevas para seleccionarlo en la instalación si aparece en la lista de drivers de red
    - no marques nada específico de AMD.

  8. #8
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    muchas gracias por tu info, hare tal como dices, ya tengo la version kalyway 10.5.2, ya comentare ke tal me fue

  9. #9
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    He averiguado esto de mi placa, lo digo para quien tenga la misma que yo y quiera probar de instalar el kalyway:

    Tipo conjunto de chips Intel G33 Express / Intel ICH9
    Controlador gráfico Intel GMA 3100
    Códec de audio Realtek ALC883
    Adaptador de red - Marvell Yukon 88E8056

    Para el adaptador de red durante la instalacion no he encontrado nada, por lo demas he podido seleccionar el mas adecuado.

    A ver si tengo suerte y lo instala, ahora faltan 5 minutos

  10. #10
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    hey, por fin lo tengo, muchas gracias miliuco, con el dvd de kalyway y los chipset correctos ya me esta rulando, genial.

    Ya probare como configurar la red, pues no me deja navegar.

  11. #11
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Para la red:

    - mira ésto

    - las Marvell Yukon 88E8053 suelen funcionar con los drivers nativos de Leopard, es una pena que la tuya no aparezca bien reconocida pues son similares

    - aprovechando el punto anterior, modifica la extensión AppleYukon.kext de esta manera reiniciando el PC después (comentarios en inglés) (has de tener activado el usuario root) (créditos a Rammjet):
    cd /System/Library/Extensions <-- changes directory
    sudo nano IONetworking.kext/Contents/PlugIns/AppleYukon.kext/Info.plist <-- edits file

    (find and change: <key>Yukon-88E8053</key>)
    (to: <key>Yukon-88E8056</key>) <-- change "53" to "56"

    (find and change: <string>Yukon Gigabit Adapter 88E8053</string>)
    (to: <string>Yukon Gigabit Adapter 88E8056</string>) <-- change "53" to "56"

    (find and change: <string>0x436211AB</string>)
    (to: <string>0x436411AB</string>) <-- change "62" to "64"

    (press Control-O) <-- saves changes
    (press Y and Enter) <-- accepts saving to existing file
    (press Control-X) <-- exits nano

    sudo chown -R root:wheel IONetworkingFamily.kext <-- repairs permissions
    cd /System/Library <-- changes directories
    sudo rm -rf Extensions.mkext Extensions.kextcache <-- rebuilds kextcache on reboot

  12. #12
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    si ya haba mirado lo que se decia en este post, pero hablan de modificar appleYukon.kext y a mi no me aparece, me aparece appleYukon2.kext que en ese post dicen ke ahi ke eliminar.

    Mi pregunta es: esto supongo ke es un drivers, lo puedo añadir ahora con el cd de instalacion o de otra forma?

    Gracias por tu paciencia

  13. #13
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Si yo busco dentro de mi archivo IONetworkingFamily.kext en su carpeta Contents/PlugIns veo AppleYukon.kext y AppleYukon2.kext (entre otros archivos), ¿te pasa lo mismo?:
    JUKER:~ pol$ cd /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns/
    JUKER:PlugIns pol$ ls
    Apple_DEC21x4Ethernet.kext
    Apple3Com3C90x.kext
    AppleBCM5701Ethernet.kext
    AppleBCM5751Ethernet.kext
    AppleGMACEthernet.kext
    AppleIntel8254XEthernet.kext
    AppleIntel8255x.kext
    AppleRTL8139Ethernet.kext
    AppleRTL8169Ethernet.kext
    AppleUSBEthernet.kext
    AppleUSBGigEthernet.kext
    AppleYukon.kext
    AppleYukon2.kext
    Entonces se trataría de modificar AppleYukon.kext según las instrucciones de Rammjet y reiniciar. En principio yo no eliminaría AppleYukon2.kext, si falla aún con AppleYukon.kext modificada probaría eliminándolo.
    Para cualquiera de estas tareas requieres tener activado el usuario root, cuando escribes sudo delante de un comando en Terminal te pide la contraseña de root que has de configurar cuando activas root (Aplicaciones >> Utilidades >> Utilidad de Directorios >> Edición >> Activar usuario root).

  14. #14
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    no a mi el AppleYukon.kext no me aparece solo me aparece AppleYukon2.kext, puedo copiarlo y pegarlo ahi o eso no serviria?

  15. #15
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Prueba a meter este que te adjunto en la carpeta PlugIns y lo modificas (o al revés, primero lo modificas y luego lo copias a plugIns).
    Archivos Adjuntos Archivos Adjuntos

  16. #16
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    Pues no no consigo instalar la puñetera red.... que asco.
    El problema creo que lo tengo al crear usuario root, he seguido tus pasos (Aplicaciones >> Utilidades >> Utilidad de Directorios >> Edición >> Activar usuario root).
    Lo activo pero luego en terminal me dice que lo intente de nuevo y a la 3 contraseña incorrecta. He porbado cambiar 3 veces la contraseña y nada. He activado y desactivado el usuario root y tampoco.

    Por ultimo he seguido los pasos que decias en otro post Activar el usuario root:

    Método 1: abre Terminal y teclea [COLOR=darkblue]sudo passwd root[/COLOR], se pide una clave para usar con root

    Método 2: abre Terminal y teclea [COLOR=darkblue]dsenableroot -u usuario [/COLOR]donde usuario ha de tener privilegios de Administrador; se pide la clave del usuario y posteriormente la que se va a usar con root

    Pero me dice igual que la contraseña no es correcta.

    Al instalarlo no le puse ninguna contraseña de administrador. Puede ser eso?

  17. #17
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    lo del ususario roort ya lo tengo controlado, era por la contraseña de administrador tenia que establecerla primero.

    lo que me falta ahora es hechar a andar la red, los pasos que me indicas abajo no me kedan claros, pues dice que debo modificar (Yukon Gigabit Adapter 88E8056</string>) <-- change "53" to "56") y asi me aparece sin modificar en el kext ke tu me diste.

    En terminal que debo escribir: sudo chown -R root:wheel IONetworkingFamily.kext
    y luego
    sudo rm -rf Extensions.mkext Extensions.kextcache
    y despues reiniciar???

    Gracias

  18. #18
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    alguien tiene otra idea

    le he instalado varios programas, pero sin red como ke no, Y me gusta mucho este SO, a ver si alguien sabe como hacer funcionar la dichosa red

  19. #19
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Pues poca idea más te puedo dar.

    Como último recurso, existen en el mercado tarjetas Ethernet para PCI, modelo Realtek RTL8139, que son muy baratas y suelen funcionar perfectamente tanto con Tiger como con Leopard.

  20. #20
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    gracias por tu ayuda, tocara gastarse las pelas otra vez, comprare esa ke dices.

    Saludos

  21. #21
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    ey, lo tengo jejeje, lo reinstale, seleccionando los drivers correctos mavell yukon, y listo

    Siento la lata, gracias por tu preocupacion, que le sirva a otros, leopard funciona con esta placa a las mil maravillas, reinicia perfectamente y se apaga conpletamente el kernel ke uso es el slep

  22. #22
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    una ultima......... pregunta. Exite otro drivers para la grafica, Intel GMA 3100, lo digo por qque solo me deja una configuracion 1024x768.

    Tendrias algo

  23. #23
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    No, para esa x3100 por ahora nada. Lo que se puede hacer es poner una gráfica PCI express (ej: ATI Radeon 2600XT de 256 mb o NVidia 8800GT de 512 mb).

  24. #24
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yonyvane
    vale gracias, por ahora me apañare asi

  25. #25
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Puedes usarlos así pero, como no tienes aceleración gráfica, algunos programas no funcionarán o funcionarán mal (reproductor de DVD, Dashboard, reproducción de algunos vídeos, etc...).

Página 1 de 2 12 ÚltimoÚltimo

Notas relacionadas que te pueden interesar

  1. no puedo Instalar Leopard con placa asus
    por zapikero en categoría OS X 10.5
    Comentarios: 5
    Último comentario: 25/07/10, 22:13:33
  2. instalar Leopard en ASUS 1000H
    por Efra1 en categoría HackinBook
    Comentarios: 4
    Último comentario: 02/02/09, 23:49:45
  3. Tutorial instalar Mac OS X Leopard nativo ASUS 1000H
    por williamnanio en categoría OS X 10.7
    Comentarios: 0
    Último comentario: 01/02/09, 11:07:03
  4. Instalar iAtkos 2.0i Leopard Asus P5GC-M 1333
    por hidros en categoría OS X 10.5
    Comentarios: 1
    Último comentario: 25/06/08, 19:55:54
  5. Como instalar leopard en un Asus G1
    por khoner en categoría OS X 10.5
    Comentarios: 1
    Último comentario: 16/04/08, 14:48:38