Página 1 de 2 12 ÚltimoÚltimo
  1. #1
    fallen_21
    Internet

    Solucion problemas USB en mac osx

    Bueno, creo que es mi primer post "interesante", no tiene mucha ciencia pero... creo que servirá de algo.

    En relacion a los problemas con los controladores USB, en la pagina oficial de apple existen controladores actualizados que resuelven el problema segun el kernel instalado.

    Como no estoy acostumbrado a las rules del foro no se si es conveniente dar el link pero como es de pagina oficial no creo que haya problemas, sino pues... alguien hará su trabajo :)

    Drivers USB Mac OS X (IOUSBFamily.kext)

    A mi me funciono todo perfecto
    A disfrutar :DD


  2. #2
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    Hola

    Gracias colega, es un link muy intesante para guardar en favoritos
    A veces me pierdo buscando cualquier cosa por la web developer.

  3. #3
    DARKNESS10
    Internet
    No solo es un link muy interesante. !Funcionaaa!.

    Gracias...

    Llevaba tiempo preguntando sobre este tema y nadie me daba una respuesta tan buena, rapida y funcional como esta.

    Asi que sin temor a repetirme...

    Gracias.

  4. #4
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad Manu
    Avatar de Manu

    Esta noche cuando llegue a casa probaré esto de los usb, aunque espero que cuando pruebe la 10.4.8 de JaS ya me funcione sin hacer nada:DD

    Saludos

  5. #5
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad Fulgente
    Avatar de Fulgente

    Me ha resuelto el problema de los USB, muchas gracias. Lo que me pasaba era que para que me detectara lo que conectaba en el USB, tenía que conectarlo a través de un HUB USB. Pero despues de instalar estos drivers, lo puedo hacer directamente. :)

  6. #6
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad natch
    Hola, muchas gracias por el link, si mi computadora tiene AMD puedo instalar esto?

  7. #7
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad El Aprendiz
    Avatar de El Aprendiz

    Cita natch dijo: Ver Mensaje
    Hola, muchas gracias por el link, si mi computadora tiene AMD puedo instalar esto?
    Hola natch, te servira perfectamente siempre y cuando abras el Terminal y teypeas "uname -a" sin las comillas y te saldra que tipo de version de kernel tienes instalado y asi lo buscas en el link q el amigo fallen_21 nos deja.

    Saludos.

    Me edito, estuve revisando el link y veo que tienes q ver q tipo de build tienes instalada esto lo sabes si te vas al menu de la manzana y das click donde dice Acerca de Este Mac ahi te saldra esto por ejemplo 10.4.8 y si le das sobre el click de cambiara al tipo de build q tengas, espero haberme explicado.

  8. #8
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad natch
    TE Agradezco un monton Aprendiz.. me sirvio mucho tu ayuda y ya me funciona. Ahora solo me queda solucionar el audio que me funciona de un solo lado .. pero ya funciona muy bien mi Hackintosh.

    Muchas gracias por el link tambien

  9. #9
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad El Aprendiz
    Avatar de El Aprendiz

    Para nada amigo natch, y gracias a ti porque ahora otros sabran como buscar su build.

    Saludos.

  10. #10
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad swos
    Pues yo debo ser tonto porque no me entero de nada, lo único que sé es que los usb no me funcionan. Tengo instalado uphuck 1.4a
    ¿Que debo hacer?

  11. #11
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad santidemax

    No Aparece mi Versión y Build

    Hola Tengo un AMD 64 - 3000+ con una placa Asus A8V Deluxe corriendo MAC Tiger OS X, Versión 10.4.1 Build 8B1025. Cuando busco en la web, no aparece esa versión y build, bajé la única de 10.4.1 pero no me funciona. El SO funciona genial, me faltarían los USB y la Placa de Sonido.
    Si alguien puede ayudarme, se los Agradezco desde ya... Saludos.

  12. #12
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad lord camelot
    ¿Alguien podrá subir el Driver para Leopard 10.5.2?

  13. #13
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad chanchadaniel
    mi build es 9C7010 y no ahi version para esa...
    como ago? mis usb todavia no andan!
    si alguien tiene para ayudarme, trate en instalarle la ultima version pero no tube resultados positivos...

    saludos y gracias de antemano...

  14. #14
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad amdmac_sempron
    hola, si tengo un amd sempron me lo puedo instalar??? otra cosa, mi pen drive es un hp v120w de 2gb. puede ser que no me funcione por problemas d incompatibilidad??????
    gracias

  15. #15
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad amdmac_sempron
    Cita amdmac_sempron dijo: Ver Mensaje
    hola, si tengo un amd sempron me lo puedo instalar??? otra cosa, mi pen drive es un hp v120w de 2gb. puede ser que no me funcione por problemas d incompatibilidad??????
    gracias
    por cierto, hay que hacerse una cuenta en developer para poder descargarselo???? la cuenta es gratuita o de pago???

    gracias

  16. #16
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad catalan
    Avatar de catalan

    tengo Mac OS X 10.5.2 (9C7010) y ahora funciona algo mejor....

    tengo que aclarar que por ejemplo el pendrive lo monta cuando le da la gana, y el disco externo no lo monta.
    solucion: reiniciar el ordenador con el pendrive o disco externo conectado para que lo monte.
    mi placa intel D945PSN con os 10.5.2 reconoce como usb 2.0

    saludos

  17. #17
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad javierhe
    Hola catalan,

    Yo también tengo esa versión, me funcionan los puertos usb pero como 1.1, cuando son usb 2.0. Mi placa tiene chipset intel 915. Has conseguido que te funcione como usb 2.0 ?

    Gracias.
    Un saludo.

  18. #18
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad javierhe
    Por si sirve de utilidad a alguien : probando con varias versiones de los kernel 9.2.0 y 9.2.2 he visto que en el fichero system.log, aparecía que no se podía cargar AppleUSBEHCI, que está como plugin de IOUSBFamily.

    Revisando la extensión IOUSBFamily he visto que tenía dependencia de IOPCIFamily, versión 2.1, pero en mi sistema tenía instalada la versión 1.7. Cambiando el archivo Info.plist he conseguido que se cargue correctamente, y ya me funcionan los puertos como USB 2.0

    Saludos.

  19. #19
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Javierhe: muy interesante tu aportación, es algo en lo que normalmente no se piensa, sería muy útil que hicieses un texto breve explicativo del proceso, por ejemplo cómo miras las dependencias de una extensión, o dónde se puede leer System.log (aunque ésto es más básico) y cómo has hecho tú el proceso, seguro que puede ayudar a más de uno. Puedes ponerlo en la sección de Tutoriales Hackintosh.

  20. #20
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad SsAx

    Re: Problema con USB

    Hola a todos, fijense que yo tambien tengo problemas con el USB, tengo el Mac OS X 10.5.2 (9C7010) y al instalar el sistema no me funcionaban los USB pero baje el archivo iousbfamily 308.4 y se soluciono el problema, me montaba al conectar los usb y me los desmontaba sin problema, perrooooooo. al momento de reiniciar la maquina se perdia, alguien me puede orientar en una solucion para esto ya que es lo ultimo ke me hace falta ke funcione en mi MAC x86, tengo una placa madre foxconn 945GCMC y todo funciona de maravilla menos los USBs ayuuuuuda

  21. #21
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad Elfherk
    Avatar de Elfherk

    no monta pendrive

    Hola a todos, ojala me puedan ayudar lo que sucede es lo siguiente: conecto mi pendrive a cualquier usb que tengo en mi maquina no se monta, ni lo lee, ni lo reconoce ni nada, (en una ocasion ocasiono kernel panic), lo curioso es que solo me sucede con los pendrive, otros dispositivos (camara web, camara digital, impresora, etc) si los reconoce y los puedo usar sin problema alguno, tengo actualizada a 10.5.3 con kernel 9.3.0 modbin, este problema surgio de la nada ya que cuando recien actualize el sistema si funcionaban, ya actualize con el enlace que esta aqui, baje iousbfamily para este kernel y nada.......

    Saludos.....

  22. #22
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    ¿Los pendrive tienen algun formato especial, NTFS o asi?

    Cuando no monta nada esta claro que el kext no corresponde con la version del kernel instalado pero si te monta el disco interno de una camara web y otros chismes fallando solo el pendrive es raro.

  23. #23
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad Elfherk
    Avatar de Elfherk

    Asi es, por ejemplo tengo una camara digital con memoria sd, la conecto al usb y monta perfectamente la unidad, sin embargo, cualquier pendrive (he probado varios, unos con fat otros ntfs inclusive nuevos (desconozco con q formato vengan de fabrica)) y en ninguno de los casos lo monta, el ipod tampoco lo reconoce, es algo muy extraño, ya que como menciono anteriormente y con el sistema ya actualizado si los montaba, y supongo que no son los puertos usb, debido a que si reconoce y monta camaras digitales

  24. #24
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad infact

    a mi no me funcionan los usb teniendo la misma version de Kext y de Kernel

    hola , a mi, el problema, esque solo me lo reconoce si cuando arranca Tiger tengo conectado el USB, ya que si nos, una vez arrancado, no hay manera de que lo reconozca, tengo el kext y el kernel a la misma version, la de ToH 8.10.1, y ya nose que hacer, me he descargado el iosubfamily de mi version 10.4.11 y nada, no me ha solucionado asbolutamente nada, ya nose que hacer para poder solucionarlo, porque la verdad, es un coñazo tener que reiniciar si queires meter un pen, si alguien puede ayudarme que me lo diga y le mando cualquier especificacion del portatil que necesite... muchisimas gracias de antemano

  25. #25
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad andresin
    Avatar de andresin

    yo estoy igual que infact pero con leopard, ya lo que he echo es dejar un pendrive conectado detras para que no moleste, y ya cuando arranca con el pendrive y lo detecta la bios funciona todo con normalidad, pero es una solucion muy poco practica, seguro que hay otra forma

Página 1 de 2 12 ÚltimoÚltimo

Notas relacionadas que te pueden interesar

  1. Guía DSDT- OSX86 - Solución problemas Time Machine
    por roisoft en categoría OS X 10.7
    Comentarios: 8
    Último comentario: 17/09/09, 08:06:25
  2. Comentarios: 0
    Último comentario: 09/09/09, 08:06:15
  3. Solución para problemas de reposo en 10.5.8
    por miliuco en categoría OS X 10.7
    Comentarios: 11
    Último comentario: 20/08/09, 00:17:53
  4. Problemas con Audio in-out solucion por USB
    por performma en categoría Tarjetas de Audio
    Comentarios: 23
    Último comentario: 03/04/08, 19:59:56
  5. Solucion maxxuss
    por anmarsan en categoría OS X 10.5
    Comentarios: 0
    Último comentario: 30/09/06, 20:40:43