1. #1
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    Instalacion Snow Leopard en PC, la build 10A394

    Pues eso, leo pocos comentarios de la gente que tenga instalado snow leopard en sus ultimas betas

    Y la verdad es que me extraña mucho por que se instala igual de bien en nativo que el leopard.



    En mi caso pinchar en un HD externo, restaurar, instalar PCEFI 10, instalar los kext adjuntos y andando

  2. #2
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad ramjavi
    Avatar de ramjavi

    Excelente Juker12! A propósito, justo estaba por postear si alguien tenía experiencia con el pcefi v10, que tal te ha ido? Saludos

  3. #3
    La tengo instalada funcionando a las mil maravillas en modo 64 bits, adjunto capturillas :)

  4. #4
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad gorki
    Avatar de gorki

    Saludos, por mucho que lo he intentado no consigo instalarlo, me podríais indicar los pasos, lo he intentado con el cd swap que instale el leo, pero el snow no me lo instala.

  5. #5
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    Cita gorki dijo: Ver Mensaje
    Saludos, por mucho que lo he intentado no consigo instalarlo, me podríais indicar los pasos, lo he intentado con el cd swap que instale el leo, pero el snow no me lo instala.
    Hola:
    Mira aquí:
    http://www.applesana.es/41/19539/mac...-6-10a380.html

  6. #6
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad gorki
    Avatar de gorki

    Gracias uzmi, pero ese manual es el que sigo, y solo consigo arrancar con la manzana y se pone la pantalla negra y con el puntero dando vueltas, no pasa de ahí, vale continuare probando

  7. #7
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad roisoft
    Avatar de roisoft

    Salu2!!

    Os adjunto algun kext mas recompilado en 64bits
    Archivos Adjuntos Archivos Adjuntos

  8. #8
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad cfernand
    Avatar de cfernand

    Una duda tonta:
    Es la build 9A394 ó 10A394.
    Saludos

  9. #9
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    10A cfernand que soy un dedos, ya edite mi post

  10. #10
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad cfernand
    Avatar de cfernand

    Cita juker12 dijo: Ver Mensaje
    10A cfernand que soy un dedos, ya edite mi post
    Thank you very much.
    Ahora a buscar por esos mundos dónde se encuentra la mencionada build.
    Gracias y saludos

  11. #11
    creo q solo esta disponible desde el software update, tendras q instalar la 10A380 y actualizar a la 10A394.

  12. #12
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad cfernand
    Avatar de cfernand

    Cita godisnotalive dijo: Ver Mensaje
    creo q solo esta disponible desde el software update, tendras q instalar la 10A380 y actualizar a la 10A394.
    Gracias por la información.
    Saludos

  13. #13
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    Pues la cosa va corre que te pillo

    Update 10A402

  14. #14
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Hola a todos, he probado animado por Juker pero en mi placa no ha sido tan fácil.
    La instalación de Snow en otra partición o disco desde un disco con Leo sale bien tanto desde imagen ISO como desde DVD. Luego instalo los kext de 64 bits y el gestor de arranque. Y pongo un DDST.aml con gráfica 8800gt (el que uso en Leopard).
    Pero Snow sólo arranca si tecleo en el prompt -x64, si no tecleo nada o tecleo -x32 no arranca.
    Y cada vez que arranco Leopard se resetea la CMOS de la placa base Gigabyte Ep35-DS3r. Respecto a este punto os comento que Stellarola en el foro pitinglis tiene un hilo titulado
    **Definitive CMOS Reset fix**, Tested on Gigabyte, ABit, DFI, ASUS, and MSI
    que parece resolver este problema con una maniobra muy sencilla, no sé si alguien lo ha probado.
    Y lo más importante de todo es que arranque como arranque a los pocos minutos de estar en marcha sale un KP y hay que reiniciar a lo bruto.
    Así que por ahora la experiencia ha sido poco atractiva pero al menos he visto los procesos en Monitor de Sistema a 64 bits.

  15. #15
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Probando la propuesta por Juker y la 10a380

    He probado el fix de Stellarola y efectivamente elimina el reseteo de la CMOS, simplemente con la modificación propuesta en el DSDT. Al menos en mi hardware, ver firma.
    La sección RTC del archivo DSDT.dsl la he dejado así:

    Al menos esa molestia de tener que configurar la BIOS ha desaparecido pero por más que lo he intentado no consigo que desaparezca ese KP aleatorio que sale cuando Snow lleva unos minutos en marcha, a veces pocos minutos y a veces más de un cuarto de hora.
    He probado con la compilación que comenta Juker y también con la 10a380 y con ambas me pasa.

  16. #16
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad roisoft
    Avatar de roisoft

    Actualizado mi post previo con más kext x64


    Miliuco, prueba a inyectar la ID de tu ICH9R en el ESB2 AHCI, lo puedes hacer directamente en el kext o añadiendo esto en tu dsdt, seccion IDE1/SATA (depende de como lo tengas)


    Method (_DSM, 4, NotSerialized)
    {
    Store (Package (0x02)
    {
    "device-id",
    Buffer (0x04)
    {
    0x81, 0x26, 0x00, 0x00 // ESB2 AHCI ID , tu ICH9R será detectado como ESB2 y tus discos como internos
    }
    }, Local0)
    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
    Return (Local0)
    }

  17. #17
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Efectivamente, Roisoft, con ese código en DSDT los discos se muestran con el icono clásico de disco interno de OSX, gracias por el truco, me sigues dejando "pasmao".

    El KP aleatorio a los pocos minutos de arrancar se va si desactivo de alguna manera mdworker (de 32 bits sobre todo) y Spotlight pero sin éso aparece inevitablemente.

  18. #18
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad gorki
    Avatar de gorki

    No consigo instalar, ni desde el DVD ni desde la partición en el HD usb, alguno de vosotros me podria detallar los pasos correctos a seguir.
    Me he agenciado un HD usb, le he creado una partición de 10 gb, he restaurado el systema y borrado el disco, reinicio y selecciono el usb, se pone en marcha pero se queda colgado con la pantalla en negro y el cursor dando vueltas (la ruedecita de colores )

  19. #19
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad charlszone2
    Cita roisoft dijo: Ver Mensaje

    prueba a inyectar la ID de tu ICH9R en el ESB2 AHCI, lo puedes hacer directamente en el kext o añadiendo esto en tu dsdt, seccion IDE1/SATA (depende de como lo tengas)


    Method (_DSM, 4, NotSerialized)
    {
    Store (Package (0x02)
    {
    "device-id",
    Buffer (0x04)
    {
    0x81, 0x26, 0x00, 0x00 // ESB2 AHCI ID , tu ICH9R será detectado como ESB2 y tus discos como internos
    }
    }, Local0)
    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
    Return (Local0)
    }
    Yo para ICH10 he añadido la id 3a22:




    Sigue sin detectarlos como internos. Me los detecta como internos solamente si uso esta extensión
    Hablo de 10.5.8...
    No es importante pero ¿Debería funcionar solo con el código dsdt? ¿sin la extensión?

    Saludos
    Archivos Adjuntos Archivos Adjuntos

  20. #20
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad roisoft
    Avatar de roisoft

    Tu placa ya tiene ID nativa del ICH10/R , el añadirle esa ID no cambia nada, algunas placas con ICH10/R nativo, sobre todo GA y Asus (estas últimas en su version x58) necesitan de ese legacy del que hablas para fijar los iconos a internos, aunque si inyectas la ID del ESB2 AHCI via dsdt debería de funcionar tb... de cualquier modo sean internos os externos los iconos no afectan al rendimiento..

  21. #21
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad charlszone2
    Cita roisoft dijo: Ver Mensaje
    Tu placa ya tiene ID nativa del ICH10/R , el añadirle esa ID no cambia nada, algunas placas con ICH10/R nativo, sobre todo GA y Asus (estas últimas en su version x58) necesitan de ese legacy del que hablas para fijar los iconos a internos, aunque si inyectas la ID del ESB2 AHCI via dsdt debería de funcionar tb... de cualquier modo sean internos os externos los iconos no afectan al rendimiento..
    Ok, gracias roisoft ;-)

Notas relacionadas que te pueden interesar

  1. Snow Leopard Universal 10.6 BUILD 432 GM-v3.5 PC
    por mislata en categoría OS X 10.6
    Comentarios: 15
    Último comentario: 26/10/09, 17:48:34
  2. Descarga Mac OS X 10.6 Snow Leopard (Build 10A421)
    por matrix en categoría OS X 10.6
    Comentarios: 3
    Último comentario: 12/08/09, 09:29:24
  3. Mac OSX Snow Leopard 10.6 build 10a261
    por Coquy en categoría OS X 10.6
    Comentarios: 3
    Último comentario: 12/05/09, 12:55:59
  4. Snow Leopard Build 10A286 enviada a los Developer
    por juker12 en categoría OS X 10.6
    Comentarios: 0
    Último comentario: 09/03/09, 11:46:20
  5. Mac OS X 10.6 Snow Leopard Build 10A190
    por juker12 en categoría OS X 10.6
    Comentarios: 9
    Último comentario: 29/12/08, 14:41:24

Etiquetas en este tema