1. #1
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad enrick

    Problema con arranque en Snow Leopard

    Hola a todos, como va todo? Hace unos dos años un miembro de este foro me ayudó a instalar Mac Os X Leopard en un Pc. Todo ha ido de maravilla hasta hace media hora. Resulta que en su dia instalé el OSX en un disco de 80Gb peró se me quedó pequeño y volví a hacer una nueva instalación en un disco de 320Gb. Los dos discos siguen estando instalados en la maquina pero solo trabajo con el de mayor capacidad. Esta mañana al encender, ha arrancado sin problemas pero se ha quedado la pantalla fija y bloqueada. Cuando he vuelto a reiniciar, ha hecho el proceso normal hasta la pantalla de carga, la que sale fondo gria con la manzanita y la rueda giratoria de carga. Entonces me ha aparecido un icono de prohibido encima la manzana de ahí no pasa. Le he estado dando vueltas y mirando por internet y lo unicó que he descubierto es que en la BIOS la hora era incorrecta, de tanto en tanto se atrasa dos horas clavadas y el BUS estaba en IDE i no en AHCI. Al cambiar estos parametros en BIOS, la maquina me arranca con el disco de 80Gb pero no con el que me interesa de 320Gb. He hecho lo del disco de arranque de las ultilidades y me sigue arrancando con el de 80Gb. Le he cambiado el boot a la bios y entonces el sistema se me queda clavado en la pantalla de carga, pero esta vez no me sale ni el icono circular de carga, aparece la pantalla gris con la manzana y ahí se queda. Le he hecho un verificar y repara disco pero ya no se me ocurre nada. Ha podida ser algo de la BIOS? A veces cuando arranca me hace tres pitidos , pero de tanto en tanto. Lo de la hora es raro ya que en lo que llevo de mañana la he cambiado un par de veces. Me podrias ayudar?


  2. #2
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    Hola:
    Prueba a cambiar la pila de la placa base si la tienes desde hace mucho, a veces cuando le queda poca vida, se desconfigura los parámetros de la bios, entre ellos la hora.

    También comprueba los demás ítems, (AHCI, Hpet mode, ACPI suspend, etc) o sea todo aquello que hayas modificado en tu bios para que OSX funcionase.

    Luego en el momento de la carga del sistema del HD de 320 Gb (desde cCameleon si es lo que usas) escribe -v
    Mira donde se detiene o si hay algún tipo de aviso que de una pista de lo que está pasando.

    Un saludo.

  3. #3
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad enrick
    Cita uzmi dijo: Ver Mensaje
    Hola:
    Prueba a cambiar la pila de la placa base si la tienes desde hace mucho, a veces cuando le queda poca vida, se desconfigura los parámetros de la bios, entre ellos la hora.

    También comprueba los demás ítems, (AHCI, Hpet mode, ACPI suspend, etc) o sea todo aquello que hayas modificado en tu bios para que OSX funcionase.

    Luego en el momento de la carga del sistema del HD de 320 Gb (desde cCameleon si es lo que usas) escribe -v
    Mira donde se detiene o si hay algún tipo de aviso que de una pista de lo que está pasando.

    Un saludo.
    Hola, primero de todo, gracias por responder. Intentaré cambiar la pila mañana, ya que cada vez que enciendo el pc, me encuentro con la hora cambiada, en concreto dos horas menos de la real. Cuando me comentas que mire los items AHCI, Hpet mode, ACPI..... no recuerdo como los tenia antes de la incidencia. El IDE conf lo tenfo el AHCI configuration SATA. Respecto al ACPI tengo dos ITEM: ACPI 2.0 en disableb y ACPI APIC en Enabled. Respecto a Hpet, no lo encuentro en mi BIOS. Cuando entro en el boot apretando la tecla ALT Mayus me sale una pantalla con los dos discos duros instalados, me coloco sobre el de 320, que es el que me interesa arrancar y con el que he estado trabajando hasta ahora, y lo selecciono para escribir el -v. De repente aparecen un monton de lineas de comando hasta que se detiene en PCI configuration begin, y de ahí no pasa.

  4. #4
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    Hola enrik:
    PCI configuration begin es un error que aparecía en los hack al actualizar a 10.6.8 o a Lion.
    Te dejo un link de un blog donde se habla del tema, espero que te ayude.


    Si no logras solucionarlo, avisa y veremos que se puede hacer.

    Trata de poner en tu firma datos de tu equipo para saber de que estamos hablando.

    Referente a los parámetros de la bios depende un poco de la placa que tengas, en mi caso por ejemplo va SATA AHCI - Enabled (en lugar de ide)
    ACPI Suspend Type - S3 y HPET mode - 64 bit

    Un saludo

  5. #5
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad enrick
    Hola de nuevo, le he puesto la pila y he vuelto a configurar la BIOS como creo que estaba antes. Le he hecho lo de editar la DSDT y todo sigue igual. Es muy raro ya que si fuera un problema de la version 10.6.8 me ha habria saltado antes. COmo ya te comenté la maquina me ha fumcionado sin problema durante años. Se me ha ocurrido copiarle en la carpeta Extra el archivo dsdt.aml que tenia guardado en backup y el cual me funcionaba correctamente. Se me ocurrió que si el disco de 80Gb me arranca sin problemas, puedo cojer el DSDT y copiarlo a la carpeta extra del disco de 320GB para ver que pasaba, me da el mismo error. Es muy extraño que de la noche al dia me haya dejado de funcionar. Hay un usuario que dice que a él le ha funcionado con /E/E EvilAppleACPIPlatform.kext y EvilIOPCIFamily.kext con un placa parecida a la mia. Como puedo hacer ese metodo? no tengo ni idea ni tampoco lo explica. COmo puedo poner las caracteristicas de mi equipo en la firma? He ido a mi perfil y no encuentro lo de la firma. Gracias.

    Asus P5B Rev. 1102
    Intel Core 2 Duo 2,4Ghz
    4GB DDR2 SDRAM 667Mhz
    HD ST380013AS
    HD ST3320620AS
    GForce 8600 GTS
    Sony DVD RW AW-G170A

  6. #6
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    Hola:

    Para la FIRMA:
    En la cabecera de la página, click en Enlaces, sale un menú y allí está la opción--> Editar firma
    Lo de la firma es interesante porque a veces lees un post de varias páginas y tienes que ir al comienzo a ver que equipo tiene quien esta posteando.

    Entra en el OSX del HD pequeño y sube una imagen de Acerca de este Mac:
    Icono Manzana--> Acerca de este Mac

    Luego le das a Control + Alt + 4 (para obtener una captura de pantalla) y lo subes.

    por si quieres que tus capturas sean en formato jpg, que ocuparan menos espacio (mas livianas mas fáciles de subir)

    Si te complica o estás falto de tiempo posteas entonces que dice aquí donde te marco con un ovalo:

    1.jpg

    Si tienes Ruindos con Aida 64 extrae el dsdt sin modificación alguna y también lo posteas.

    Un saludo.

  7. #7
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad enrick
    Hola de nuevo, ya he subido la configuración de la maquina y la imagen de la info dels sistema con el disco que me funciona. Lo que me pides de Ruindos con Aida 64 no se lo que es, disculpa. Que debo hacer?

  8. #8
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    Cita enrick dijo: Ver Mensaje
    Hola de nuevo, ya he subido la configuración de la maquina y la imagen de la info dels sistema con el disco que me funciona. Lo que me pides de Ruindos con Aida 64 no se lo que es, disculpa. Que debo hacer?
    Hola: No veo la imagen pero dime que dice en Acerca de este Mac por favor

    Donde dije Ruindos digo Windows :
    Lo que te pido es el dsdt puro sin modificar que se extrae desde windows con el programa Aida64.

  9. #9
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad enrick
    Cita uzmi dijo: Ver Mensaje
    Hola: No veo la imagen pero dime que dice en Acerca de este Mac por favor

    Donde dije Ruindos digo Windows :
    Lo que te pido es el dsdt puro sin modificar que se extrae desde windows con el programa Aida64.

    Hola de nuevo, en la firma he puesto la conf del equipo y la foto abajo. Igualmente te digo lo que pone: Version 10.6.6 ( la del disco que quiero recuperar es la 10.6.8 ) Procesador 2.4Ghz Intel Core 2 Duo, Memoria: 4GB 667Mhz DDR2 SDRAM. No acabo de entender lo de extraer el dsdt desde windows a través de Aida64. El hackinston lo tengo montado en un pc que solo lleva OSX, no esta montado sobre un windows. Puedo enviarte el DSDT por email? Si es así, el del disco de 320GB? Es el que esta en la carpeta raiz EXTRA, no? Gracias de nuevo.

  10. #10
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    Bien, el OSX del disco pequeño no te da problemas porque es 10.6.6
    El OSX del disco mas grande te da problemas porque es 10.6.8
    Apple modificó algo en su sistema que hace que en los hack aparezca el error que tu tienes cuando pasas de 10.6.6 o 10.6.7 a 10.6.8 o a 10.7.

    Mientras usabas el OSX del HD grande y era 10.6.6 o 10.6.7 ningún problema, pero se actualizó a 10.6.8 y ahí está la faena.

    Soluciones:

    1)Actualizar el HD pequeño PERO a 10.6.7 (porque si pasas a 10.6.8 vas a tener el mismo problema del HD grande) y entonces copiar los kext AppleACPIPlatform.kextIOPCIFamily.kext a la instalación del hd 10.6.8 *

    2)Probar instalar EvilAppleACPIPlatform.kext y EvilIOPCIFamily.kext en 10.6.8 y ver si funciona. **

    3) Dejarte de remilgos y hacer una instalación limpia de 10.8 (Mountain Lion) ***

    * Los kexts que te menciono en el ítem 1) están en Sistema--> Libreria--> Extensions (S/L/E)

    ** Los kexts Evil van en la carpeta Extra--> Extensions (E/E) según Karina que dice que lo resolvió así. Tendrás que probar bajo tu propio riesgo.

    *** Tendrías un S.O. mas actual

    En Mountain Lion uso Kext Wizard para instalar kext en S/L/E o en E/E y luego reparar permisos y limpiar cache. Esto es fundamental para que funcione correctamente.
    En Snow no se cual usas para ese fin.

    Ya me dirás

    Un saludo.

    https://www.osx86spain.com/descargas...pcifamily.html

    P.D. El dsdt que tu tienes es uno ya modificado, yo quería uno sin modificar para corregirlo desde cero y que tambien te sirviera en caso de instalar Mountain Lion.

  11. #11
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad enrick
    Hola de nuevo, voy a probar la segunda opción. Lo que es extraño es que he estado trabajando durante muchos meses con la 10.6.8 sin problemas. Entiendo que las actualizaciones no son automaticas por lo que no creo que se haya actualizado solo a esa versión. Recuerdo haber pasado de l 7 a la 8 manualmente y trabajar sin problemas. Bien, ya he copiado los dos ficheros kext de EVil a la carpeta E/E. Cuando me dices instalar, a que te refieres? debo ejecutar esos ficheros? como? o solo con copiarlos y reiniciar, es suficiente?. GRacias.

  12. #12
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad enrick
    Ya estaaaaaaaaaaaaa!!!!!! He copiado y reiniciado y ha arrancado sin problemas. Muchisimas gracias por tu colaboración y ayuda. Vale la pena actualizar a Lion? Gracias por todo. Hasta pronto.

  13. #13
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    Me alegro por ti.
    Si un día tienes un Hd disponible y ganas intentamos con ML.
    Eso si tendrás que obtener tu DSDT puro para modificar
    Un saludo.

  14. #14
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad enrick
    Cita uzmi dijo: Ver Mensaje
    Me alegro por ti.
    Si un día tienes un Hd disponible y ganas intentamos con ML.
    Eso si tendrás que obtener tu DSDT puro para modificar
    Un saludo.
    Ok, por ahora iré trabajando con Snow Leopard, pero de todas formas te tomaré la palabra. Muchisimas gracias por tu ayuda. Hasta otra.

Notas relacionadas que te pueden interesar

  1. Problema arranque DVD Snow Leopard Hazard
    por 50niggaz en categoría OS X 10.6
    Comentarios: 3
    Último comentario: 27/03/10, 06:11:56
  2. problema con instalacion snow leopard
    por raydem en categoría OS X 10.7
    Comentarios: 2
    Último comentario: 04/03/10, 19:22:59
  3. problema airport en snow leopard
    por metallerium en categoría Redes / Internet
    Comentarios: 0
    Último comentario: 27/09/09, 01:06:42
  4. error Primer Arranque de Snow leopard
    por snoopamk en categoría OS X 10.6
    Comentarios: 0
    Último comentario: 09/09/09, 09:34:59
  5. Snow Leopard 64Bits con kernel default de 32Bits (modo de arranque)
    por juker12 en categoría Noticias osx86spain.com
    Comentarios: 0
    Último comentario: 29/08/09, 13:29:59

No te pierdas:

arranque snow leopard