hola a todos, primero quisiera decir que soy novato en esto de MAC y el problema que tengo es que no consigo arrancar la partición del MacOSx86 directamente.

Explico un poco como lo tengo montado:

windos xp en la primera particion la cual tengo el timeout a 0 y donde he copiado el Chain0 ,ubuntu.bin y fedora.bin en la raiz.

windows Vista en la segunda partición y es la que utilizo para el boot de los demas SO



MacOSx86 en la tercera que es donde tengo el problema la cual tengo que entrar en el darwin para poder lanzar el mac porque sino me vuelve a lanzar al boot de vista

ubuntu 7,10 en la cuarta partición montada como lógica y que botea sin problemas porque la he modificado

fedora core 7 een la cuarta partición lógica , modificada y sin problemas


Despues de mucho buscar y leerme decidí a modificar el com.apple.boot.plist y la verdad me ha costado algún susto que otro y reinstalar por ser novato, y el resustado final es:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string></string>
<string>rd=disk0s3</string>
<key>Boot Graphics</key>
<string>Yes</string>
<key>Timeout</key>
<string>10</string>
</dict>
</plist>

Cuando lanzo el Darwin tengo las opciones:

(0,1)windows
(0,2)windows
(0,3)MacOSx86
(0,5)linux
(0,7)linux

Ypor eso supongo que el string añadido esta bien "<string>rd=disk0s3</string> pero no me hace ni caso si me descuido me devuelve al boot de vista .
¿Puede ser un error de sintaxis?
¿Alguien tiene idea de que puede ser?

Espero no haber sido un plasta con este tochazo y espero y estare muy agradecido de toda ayuda prestada.