1. #1
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad synake
    Avatar de synake

    no funciona la webcam ni el blutooth en mi hackintosh con osx el capitan

    Hola amigos ...alguien puede guiarme para poder "renombrar los puertos en el DSDT....para que vuelva a funcionar la cam y el bluetooth? gracias


  2. #2
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita
    Avatar de Bebita

    Hola, es verdad que en OS X El Capitan han cambiado AppleUSBEHCIPCI.kex y AppleUSBXHCIPCI.kext en su forma de administrar los puertos USB pero yo con mi perfil no he tenido ningún problema.

    Ni siquiera he tenido que renombrar los dispositivos USB 2.0 en el DSDT a EHC1/EHC2

    ¿Qué perfil usas tú para que tipo de ordenador?


    Cita synake dijo: Ver Mensaje
    Hola amigos ...alguien puede guiarme para poder "renombrar los puertos en el DSDT....para que vuelva a funcionar la cam y el bluetooth? gracias

  3. #3
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad synake
    Avatar de synake

    Estaba usando chameleon en yosemite 10.10.5....al actualizar a osx el capitan "con clover "...no detecta la webcam integrada y el blutooth!....es una portatil sansumg! necesito me ayudes a como puedo renombrar esto en el DSDT para solucionarlo, la SIMBIOS que uso es un mac pro 8,1 nunca tube problemas :(

  4. #4
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita
    Avatar de Bebita

    Hola, yo probaría con un perfil de macbookpro9.2, otra cosa, ¿si te vas a los puertos USB que te muestra?
    attachment.php?attachmentid=7192&d=1444985080

  5. #5
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad synake
    Avatar de synake

    Hola bebita...gracias por tu orientacion..., si cambio a un SIMBIOS macbookpro9.2, tambien cambia el serial number del equipo y el UUID? ...en los puertos puertos USB muestra esto:

    Bus USB 2.0:


    Driver del controlador de host: AppleUSBEHCIPCI
    ID del dispositivo PCI: 0x3b34
    ID de la revisión de PCI: 0x0005
    ID del fabricante de PCI: 0x8086


    Hub:


    ID del producto: 0x0020
    ID del fabricante: 0x8087 (Intel Corporation)
    Versión: 0.00
    Velocidad: Hasta 480 Mb/s
    ID de la ubicación: 0x1d100000 / 1
    Corriente disponible (mA): 1000
    Corriente necesaria (mA): 0
    Corriente operativa adicional (mA): 0
    Integrado: Sí


    *QUERIA ADJUNTARTE UNA FOTO PERO NO ENCUENTRO LA OPCION ACA DENTRO :)...VEO QUE TIENE UN NOMBRE DIFERENTE DE DRIVER :(

  6. #6
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita
    Avatar de Bebita

    ¿Por casualidad tienes un portátil HP EliteBook 8440P? Es que este ID 0x3b34 me suena de este portable. Si es así quizás estamos enfocando el asunto mal y si antes te funcionaba era porque tendrías algún inyector.

    Si es así, intenta agregar tu ID a los nuevos kext del Capitan

    Exclusivo para USB 2
    /System/Library/Extensions/IOUSBHostFamily.kext/Contents/PlugIns/AppleUSBEHCIPCI.kext/Contents/Info.plist

    Y lo agregas en

    <key>CFBundleIdentifier</key>
    <string>com.apple.driver.usb.AppleUSBXHC IPCI</string>
    <key>IOClass</key>
    <string>AppleUSBXH</string>
    <key>IOPCIPrimaryMatch</key>
    <string>AQUI</string>

    O aquí

    /System/Library/Extensions/IOUSBHostFamily.kext/Contents/PlugIns/AppleUSBXHCIPCI.kext/Contents/Info.plist

    Yo para subir imágenes lo que hago es crear un Album y las subo. Después agrego el enlace a mi post.

  7. #7
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad synake
    Avatar de synake

    bebita es una notebook aca las especificaciones
    Notebook Samsung R480


    *Procesador ---> Intel Core i5
    *Chipset ---> Intel HM55
    *Placa Madre ---> R480
    *Tarjeta de Video ---> NVIDIA GeForce GT 310M
    *Audio ---> Realtek ALC269
    *Almacenamiento ---> Seagate ST9500325AS (500GB, 5400 RPM, 2.5″, SATAII)
    *Pantalla ---> LCD Hannstar HSD140PHW1 14″ 1366×768, LED-retroiluminad
    *Tarjeta de Red ---> Marvell Yukon 88E8059 PCI-E Gigabit Ethernet
    *Tarjeta de Red Inalámbrica ---> Atheros AR9285 Wireless Network Adapter
    **Bluetooth ---> Broadcom BCM2070 Bluetooth 2,1+EDR USB
    *Batería ---> Samsung Li-ion 6 celdas 11,1V 4400mAh-48Wh

    (ACTUALIZE DIRECTAMENTE DE YOSEMITE A EL CAPITAN COMO UN MAC COMUN) ...tu dices agrege...el ID...al injector ...voy a ponerte las capturas a ver si se resuelve el problema!

  8. #8
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad synake
    Avatar de synake

    asi? dime si esta bien adjuntado el ID

    3.jpg

    4.jpg
    5.jpg

  9. #9
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    Cita synake dijo: Ver Mensaje
    asi? dime si esta bien adjuntado el ID...
    Hola:
    No es eso a lo que se refiere Bebita.
    Por ejemplo aqui el Id de mis usb (uso DPCIManager para verlo)


    6.jpg

  10. #10
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad synake
    Avatar de synake

    tengo... DPCIManager ahora lo posteo a ver que me dicen!!! cuales son los puertos a cambiar

  11. #11
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad synake
    Avatar de synake

    tengo... en el DPCIManager esto...ahora cuales son los puertos a cambiar?7.jpg

  12. #12
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad milon
    Avatar de milon

    Hola synake te dejo un kext al que he añadido ese ID que has publicado. Ni idea si te funcionará.



    ¿Tu Broadcom BCM2070 Bluetooth es un pincho USB? Pensaba que en los portátiles eran una mini-pci express

    Saludos

  13. #13
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad synake
    Avatar de synake

    GRACIAS milon....cual ID dices?... el 3B3C del DPCIManager?...si es Broadcom BCM2070 Bluetooth!!!....voy a probarlo a ver si vuelve ....donde lo instalo ....en clover 10.11 Y EN OTROS? ...O EN S/L/E????

  14. #14
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    Para instalar kext yo uso Kext Utility:

    Dicha app instala los kext en S/L/E y repara los permisos.

    Personalmente prefiero los kext en S/L/E y no en la carpeta Clover (EFI)

    Cita synake dijo: Ver Mensaje
    GRACIAS milon....cual ID dices?... el 3B3C del DPCIManager?...si es Broadcom BCM2070 Bluetooth!!!....voy a probarlo a ver si vuelve ....donde lo instalo ....en clover 10.11 Y EN OTROS? ...O EN S/L/E????

  15. #15
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad milon
    Avatar de milon

    Espera un poco, ¿el 3B3C es un pincho USB que has comprado para BT? si es así no puede funcionar de ninguna manera lo que te he propuesto.

    Creo que este post no va bien. Estamos confundiendo churras con merinas. Es decir, una cosa son renombrar puertos USB por que según un perfil u otro quede desactivado o simplemente un USB 2.0 vaya a USB 3.0

    ¡Y otra cosa es que ahora no tengas un kext para un dispositivo concreto! sea ethernet, trackpad o audio

  16. #16
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad synake
    Avatar de synake

    bueno te comento....he hecho el procedimeinto de bebita.....de piner ese id (3B3C)...de DPCIManager...lo unico en toda la lista que dice USB2...llega ese codigo!!!.... y tambien istalado tu kext ....y nada....sin exito!....los USB de la portatil funcionan todos ...si yo conecto el iphone o un pendrive! funcionan todos ....solo la WEBCAM Y EL BLUTOOTH INTEGRADOS ...estan como que no tuviera nada. cosa que en yosemite en la misma portatil no me pasaba :(

  17. #17
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad synake
    Avatar de synake

    Cita synake dijo: Ver Mensaje
    bueno te comento....he hecho el procedimeinto de bebita.....de poner ese id (3B3C)...de DPCIManager...lo unico en toda la lista que dice USB2...llega ese codigo!!!.... y tambien istalado tu kext ....y nada....sin exito!....los USB de la portatil funcionan todos ...si yo conecto el iphone o un pendrive! funcionan todos ....solo la WEBCAM Y EL BLUTOOTH INTEGRADOS ...estan como que no tuviera nada. cosa que en yosemite en la misma portatil no me pasaba :(
    creo no son estos otros...los que se llaman EHC1/EHC2/XHC1)....

    tambien he aplicado este parche al DSDT ..pero nada paso :( # rename EHC1 to EH01into device label EHC1 set_label begin EH01 end;
    into_all all code_regex EHC1\. replaceall_matched begin EH01. end;
    into_all all code_regex \.EHC1, replaceall_matched begin .EH01, end;

    # rename EHC2 to EH02
    into device label EHC2 set_label begin EH02 end;
    into_all all code_regex EHC2\. replaceall_matched begin EH02. end;
    into_all all code_regex \.EHC2, replaceall_matched begin .EH02, end;

  18. #18
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad milon
    Avatar de milon

    Hola, yo tengo también dudas como bebita en el primer comentario. Lo de renombrar EHC1/EHC2 se aplica a ciertas placas base, que tras instalar OS X El Capitan pierden algunos puertos USB por la nueva forma de administrar los USB.

    Por ejemplo, los dos delanteros de tal placa base ahora están enumerados atrás. O bien, dependiendo del perfil seleccionado, sea MacPro3.1, o MacBook9.2 tienes enumerados los puertos 2,3,6,7 o 1,2,3,6,7. Renombrar y parchear vía DSDT corrige este problema.

    Pero....¿Tú estás seguro que tienes ese problema? Yo pienso que tú tienes un simple problema de kext es decir, tu ID del BT no está presente.

    Por ejemplo, ¿tú tienes puertos USB? ¿Conectas ratón, o una memoria y la reconoce?

    Y la pregunta de antes, tu BT es un pincho USB o está en una mini-pci express en tu portátil


    Saludos

  19. #19
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad synake
    Avatar de synake

    Hola MILON Y BEBITA...NO podia entrar a responderles no se que pasaba con el servidor de este sitio, ...estoy utilizando la SIMBIOS con MacBook9.2 ...en yosemite tenia mi cam y blutooth reconocidos al actualizar directamente a el capital ya no figuran. son partes intragradas de esta notebook pero no estan reconocidos , como que no exitieran. Los puertos USB funcionan correctamente ...puedo agregar discos externos ...o una memoria pendrive como dices, los reconoce perfectamente. No se a que llamas mini-pci express. he realizado el procedimiento de bebita...agrege tu kext....y tambien aplique este parche al DSDT :

    Code:
    # rename EHC1 to EH01
    into device label EHC1 set_label begin EH01 end;
    into_all all code_regex EHC1. replaceall_matched begin EH01. end;
    into_all all code_regex .EHC1, replaceall_matched begin .EH01, end;

    # rename EHC2 to EH02
    into device label EHC2 set_label begin EH02 end;
    into_all all code_regex EHC2. replaceall_matched begin EH02. end;
    into_all all code_regex .EHC2, replaceall_matched begin .EH02, end;


    Pero sigo sin exito!!! la webcam y el blutooth siguen sin aparecer :(8.jpg

  20. #20
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad synake
    Avatar de synake

    9.jpg

Notas relacionadas que te pueden interesar

  1. Apagado en OS X El Capitan no funciona
    por synake en categoría OSx86 10.11 El Capitan
    Comentarios: 19
    Último comentario: 02/07/16, 13:21:05
  2. Comentarios: 1
    Último comentario: 25/11/15, 20:59:10
  3. Instalando OS X El Capitan en nuestros hackintosh
    por senhez en categoría OSx86 10.11 El Capitan
    Comentarios: 4
    Último comentario: 12/06/15, 13:00:39
  4. Requisitos mínimos para instalar OS X El capitan en un Hackintosh
    por senhez en categoría OSx86 10.11 El Capitan
    Comentarios: 0
    Último comentario: 09/06/15, 20:42:13
  5. Drivers hackintosh webcam, audio toshiba l505 sp6984r
    por ABADGUAPITO en categoría HackinBook
    Comentarios: 2
    Último comentario: 18/02/10, 14:41:07

No te pierdas:

usb 2.0 no trabaja en hackintosh lion