1. #1
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    Controlador Realtek 8111

    Hola:
    He instalado Kalyway en un equipo que consta de:
    Intel Core 2 Duo E 6750
    P.B. Gigabyte P35-DS3L chipset intel con lan integrada Realtek RTL 8111B
    H.D. Samsung 120 Gb ide
    Memoria 2 Gb
    Gráfica Asus (Nvidia) 7300 128 Mb ampliable usando parte de la memoria instalada.

    Lo he instalado en MBR y ahora lo reinstalé en Guid.
    En ambos casos funciona exepto la red (no accedo a internet). Creo que el problema sea el driver.
    Descargué el RealtekR1000.kext y traté de instalarlo según un manual ajeno a Applesana y no pude.
    Intenté instalarlo según



    y realmente no logro nada, primero porque mi conocimiento del tema es escaso y segundo porque el ejemplo es de un driver de audio y obviamente los pasos a seguir no son exactamente iguales.
    Luego intenté seguir el consejo de 3DuArDo1293 donde se habla de un tema similar en


    y descargué RTL1xxx_1.02.pkg.zip. Lo instalo, reinicio y nada.
    Leí tambien que solo sería editar un driver con mi vendor y device de la Lan integrada
    (y que son ven 10EC dev 8168) pero no se cual driver editar ni como.




    pero cuando intento acceder al vínculo Controlador Realtek 8111B Gigabit Ethernet me dice:
    "uzmi, no tiene permisos para ingresar a esta página o acceder a las descargas, puede ser por alguno de los siguientes motivos:"
    "1 Si acaba de registrarsedeberá activar su cuenta...." y ya estoy registrado ya he activado, incluso entré al correo y volví a activar desde el mail que recibí.
    "2 Recuperar código de activación" Pido recuperarlo pero no recibo ningun mail.

    Como veran he intentado por mi cuenta bastante tiempo y veces antes de pedir ayuda pero he llegado a un punto muerto por falta de conocimientos.
    Si alguien se digna a aportar luz a mi problema le estaría muy, pero que muy agradecido.

  2. #2
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad guillerming
    Avatar de guillerming

    Bueno a ver, me metí en /System/Library/Extensions que es donde están todos los kext y anduve mirando alguno que por intuición me llevase al de realtek.

    Se llama IONetworkingFamily.kext. Click derecho, mostrar contenidos del paquete. Entramos en Contents/Plugins y ahí encontrarás el .kext de tu realtek.

    Para cambiar el vendor y el device es muy fácil. Seleccionas el kext de tu realtek, mostrar contenido del paquete y entras en Contents, ahora se trata de editar el Info.plist con el textedit.

    Llegados a éste punto tengo que confesar que éste debería ser el procedimiento, es al menos el único que conozco para cambiar el vendor y device, pero al menos en mi caso no aparecen el vendor y device en éste info.plist :S

    Si tú has tenido más suerte, lo reconocerás enseguida, será una línea así:
    <string> XXXX , XXXX </string>

    en primer lugar irá el vendor y luego el device.

    Si has llegado a completar éste paso, tendrás que ir luego a /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist

    <key>BSD Name</key>
    <string>en0</string> (cambiar el 0 por 1)

    <key>IOInterfaceUnit</key>
    <integer>0</integer> (cambiar el 0 por 1)

    Así evitaremos que la próxima vez que inicies mac os x reestablezca el vendor y el device.

  3. #3
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    Hola Guillerming:
    Gracias por responderme.
    Fuí a IONetworkingFamily.kext tal como lo indicas y en Contens/Plugin aparecen 2 kext para Realtek.
    AppleRTL8139Ethernet.kext y
    AppleRTL8169Eterneth.kext
    y la que corresponde a mi placa sería la 8168/8111 que no está.
    Ahora las dudas:
    ¿Edito igualmente aunque no correspondan? Si la respuesta es si ¿cuál de las dos? ¿Modifico solo el vendor-device o también donde dice 8139 o 8169?
    Había bajado el RealtekR1000.kext y me he fijado que su Info.Plist si contempla la 8168/8111 y traté de copiarlo en Contents/Plugin pero no me lo permite. Me dice que no se puede modificar.
    Imagino que sea por un tema de permisos desde el terminal ¿quizás?.
    No lo sé pero siento que debo estar cerca.
    Si es posible que me vuelvas a orientar...
    Gracias de nuevo.
    Uzmi

  4. #4
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    Hola de nuevo:
    Pude copiar el RealtekR1000.kext en Contents/Plugin, he modificado el NetworkInterfaces.plist y solo obtengo que no se puede usar porque fue instalado inapropiadamente, que consulte al proovedor por una actualización ( o algo así - es en inglés).
    Bajé RealtekR1000_release.pkg.zip que viene con instalador pero obtengo lo mismo.
    Edité el ApleRTL8139Ethernet.kext cambiando ven y dev y no se entera, sigue sin reconocer la tarjeta de red integrada (modificando también el NetworkInterfaces.plist) y ya no quise tocar el otro (AppleRTL8169Ethernet.kext)
    En fin, toca esperar.

  5. #5
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    Solucionado

    Hola a todos:
    Cuento mi periplo con MAC:
    Bajé Tiger 10,4,10 (el cual nunca pude instalar), Leopard 10,5 (que instalé una vez y si conectó con internet pero como no tenía sonido lo borré e intalé versiones posteriores), iATKOS_v1,0i (que tampoco podía instalar correctamente), iATKOS 1,0i a 1,0ir2 (igual que el anterior) en realidad si no pude instalarlos fué por falta de conocimientos.
    Y por último Kalyway,
    Con Kalyway instalé todo bien pero no podía acceder a internet y editando (maleditando mejor dicho) y tratando de instalar el driver RealtekR1000.kext como habrán visto arriba tampoco solucionaba nada.
    Borré y reintalé muchísimas veces cada una de las isos de Leopard que tenía y ni siquiera con la 10.5 que una vez había funcionado lograba conectarme,
    Porfiado como nunca comencé a reinstalar Kalyway pero mofificando las personalizaciones y luego de distintos intentos..LO LOGRÉ.
    Les escribo desde Leopard con mi flamante conección a Internet.
    Lo malo de todo esto es que no puedo decir con certeza al 100% que combinación fue la ganadora pero les digo que ahí está la clave.
    Recuerdo algo:
    Kernel vainilla por supuesto
    VGA nvidia injet para desktop
    Audio marqué todas y creo que aquí debería estar el problema porque antes solo marcaba azalia (segun uno de los tantos tutoriales que seguía)
    y efi mbr porque particioné en mbr
    Así que aquel que tenga una placa como la mía , que insista que es posible tener Mac,
    Gracias a todos y espero que esto le sirva a alguien en el futuro

    P.D. A los moderadores, a mi no me aparece la opción de editar así que por favor pongan en el título del hilo "Solucionado"

  6. #6
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad uzmi
    Avatar de uzmi

    A los moderadores:
    Necesito editar el post anterior o borrarlo.
    No es correcto que accediese a internet tan solo por haber cambiado los parámetros de la personalización.
    El problema está en la placa (creo)
    Cuando terminé de escribir el post me dí cuenta que no tenía audio así que a reinstalar de nuevo.
    Mientras lo hacía me dí cuenta que las luces de la tarjeta de red estaban encendidas mientras instalaba (cosa que antes no sucedía con ninguna instalación) por lo que no tiene nada que ver los parametros elegidos al instalar.
    De hecho reinstalé como lo hacía antes de ponerme a cambiar las elecciones de los parámetros eligiendo en audio solo azalia (como hacía siempre) y SI tengo internet y audio.
    Por lo visto el error debe estar el la placa fisicamente hablando,
    Tanto probar y probar y molestar a la gente para darme cuenta de esto,
    Pido disculpas por la información errónea vertida en el post anterior,
    Gracias de nuevo

Notas relacionadas que te pueden interesar

  1. mac no reconoce Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC
    por hack5 en categoría Tarjetas de Red
    Comentarios: 0
    Último comentario: 07/02/09, 14:56:00
  2. Ayuda con controlador de Sonido
    por mauricio_mg en categoría Tarjetas de Audio
    Comentarios: 1
    Último comentario: 15/08/08, 09:47:05
  3. Comentarios: 2
    Último comentario: 01/08/08, 20:05:49
  4. rtl8168/8111 para mac osx 10.4.7
    por carlos_25 en categoría Tarjetas de Red
    Comentarios: 1
    Último comentario: 13/02/07, 12:09:44
  5. Controlador ICH6 no es el mismo
    por profesionalti en categoría OS X 10.5
    Comentarios: 0
    Último comentario: 19/01/07, 02:14:41