1. #1
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad sygfrido

    Problemas con Realtek ALC888

    Dispongo de una Placa Asrock ConRoe945G-DVI, y el audio de Realtek ALC888 no me va, ¿existe algún Kext operativo para ALC888?, ¿alguna idea?, gracias de antemano.


  2. #2
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad El Aprendiz
    Avatar de El Aprendiz

    Bueno talvez te sirve esta ayuda de parte de Super Marian, suerte.

    Hola,

    Comprueba que editas correctamente tu driver, por que si tiene soporte.
    Realiza este procedimiento:

    1) navega a /System/Library/Extensions/AppleHDA.kext/Contents/Plugins/AppleHDAController.kext/Contents/info.plist

    2)agrega 0x26688086 bajo la key <key>IOPCIPrimaryMatch</key><string>0x27D88086 0x26688086</string>

    3)guardas y sales

    4)navega a /System/Library/Extensions/

    5)Borra Extensions.kextcache y Extensions.mkext

    6)Aplicaciones/Utilidades/Utilidad de Discos

    7)Selecciona tu disco duro y repara permisos

    8)Reinicia


    Nota: Es posible que los IDs aqu&#237; descritos varien ligeramente, comprueba que son iguales en tu administrador de dispositivos de windows xp.

    Saludines

  3. #3
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad sygfrido

    Gracias por la respuesta

    Aunque la solucción la encontré en estas lineas que pego aqui, por deferencia de nuevoimedio:

    Audio en la Asrock ConRoe945G-DVI podemos hacerlo en dos pasos: Solo salida de audio
    Borrar AppleHDA.kext:
    • En Terminal, escribe:
    • sudo rm -rf /System/Library/Extensions/AppleHDA.kext
    • sudo rm -rf /System/Library/Extensions.mkext
    • sudo rm -rf /System/Library/Extensions.kextcache
    Edita AppleAzaliaAudio.kext:
    • En Terminal, escribe: sudo pico /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/Info.plist
    • Buscar por (usa hotkey= ctrl + w):<key>IOHDAudioCodecVendorID</key>
    • Cambia el string a:<string>0x10ec0888</string>
    • Exit pico
    • sudo pico /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/PlugIns/AppleAzaliaController.kext/Contents/Info.plist
    • Buscar por (usa hotkey= ctrl + w):<key>IOPCIPrimaryMatch</key>
    • Cambia el string a:<string>0x27d88086</string>
    • Exit pico
    Limpiar y reparar sistema:
    • En Terminal, escribe:
    • sudo diskutil repairpermissions /
    • sudo kextload /System/Library/Extensions/AppleAzaliaAudio.kext
    • kextcache -k /System/Library/Extensions/

    Aunque no es una solución completa pero no conozco nada mejor by the moment.

  4. #4
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad periskop
    Avatar de periskop

    Hola,
    yo he hecho los mismos pasos para mi HD alc880 pero con mis device y vendor y consigo que detecte la tarjeta pero no suenan los altavoces.

    Utilizo la 10.4.7

    Saludos!!

  5. #5
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    Cita periskop dijo:
    Hola,
    yo he hecho los mismos pasos para mi HD alc880 pero con mis device y vendor y consigo que detecte la tarjeta pero no suenan los altavoces.

    Utilizo la 10.4.7

    Saludos!!

    Supongo que habras construido bien el id, si ademas de eso no te va...es posible que tu tarjeta no se active con este driver
    hay un problema muy raro en unos pocos montadores de este codec 880 y es eso, que no se activa
    para saber si es tu caso vete a windows y reinicia imediatamente y entras en osx
    escuchas ahora?

  6. #6
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad periskop
    Avatar de periskop

    Cita juker12 dijo:
    Supongo que habras construido bien el id, si ademas de eso no te va...es posible que tu tarjeta no se active con este driver
    hay un problema muy raro en unos pocos montadores de este codec 880 y es eso, que no se activa
    para saber si es tu caso vete a windows y reinicia imediatamente y entras en osx
    escuchas ahora?
    Al decir "reinicia imediatamente" te refieres en cuanto me lo permita Winxp con Start - restart, o forzando el restart en algun momento? (pregunta tonta, lo se, pero creo que ya prob&#233; el m&#233;todo)

    Lo volver&#233; a probar de todas formas

    Gracias Juker y ya te cuento!!!!!!

  7. #7
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    Eso es colega periskop

    A ver te explico mas claro.

    hay un codec, digamos 880, pero este codec lo monta varias empresas o montadores de placas base

    por lo tanto los hay mas buenos y mas malos. Ademas cada uno tiene su particularidad en cada placa

    Ahora nos vamos a hablar de osx

    ya tienes un driver, es bueno por que lo has cargado sin errores y ves que puedes configurar..pero no canta el tio
    Entonces que demonios pasa? pues que la tarjeta esta "dormida"
    Es como las tarjetas de red y el wake-lan, estan...pero dormidas


    Entonces tu driver de osx no lo ve como el resto de codec "normales" y no le envia en bit para "despertarla"

    Que hacemos???

    Nos vamos a windows y justo al iniciar y cargar el driver de audio, la tarjeta "despierta"
    Pues apagamos rapidamente windows, reiniciamos y ahora seleccionamos osx
    osx cargara el driver y como aun tu "tarjeta esta despierta" deberia funcionar


    Esto que digo es un caso muy muy particular de este codec y de algunas placas base, no se debe tomar al pie de la letra para todos los caso.

    Y por supueto...entendiendo que has editado correctamente tu ID.


    Esto tambien es muy frecuente verlo en algunas tarjetas de red y WiFI cuando arrancamos en "frio" el pc y entramos en OSX directamente sin pasar por windows.

  8. #8
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad periskop
    Avatar de periskop

    TOY SORDOOO!!

    No ha tu tia Juker. He seguido tu consejo y en cuanto win te lo permite con inicio->apagar equipo le meto, pero...NOOOOO, no suena man. a ver con esto si me pues ayudar:

    En id. de instancia del Realtek HD audio (en win) el ven es 10ec & dev 0880 y en MAC realice lo sig:

    Borrar AppleHDA.kext:
    • En Terminal, escribe:
    • sudo rm -rf /System/Library/Extensions/AppleHDA.kext
    • sudo rm -rf /System/Library/Extensions.mkext
    • sudo rm -rf /System/Library/Extensions.kextcache
    Edita AppleAzaliaAudio.kext:
    • En Terminal, escribe: sudo pico /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/Info.plist
    • Buscar por (usa hotkey= ctrl + w):<key>IOHDAudioCodecVendorID</key>
    • Cambia el string a:<string>0x10ec0880</string>
    • Exit pico
    • sudo pico /System/Library/Extensions/AppleAzaliaAudio.kext/Contents/PlugIns/AppleAzaliaController.kext/Contents/Info.plist
    • Buscar por (usa hotkey= ctrl + w):<key>IOPCIPrimaryMatch</key>
    • Cambia el string a:<string>0x27d88086</string>
    • Exit pico
    Limpiar y reparar sistema:
    • En Terminal, escribe:
    • sudo diskutil repairpermissions /
    • sudo kextload /System/Library/Extensions/AppleAzaliaAudio.kext
    • kextcache -k /System/Library/Extensions/

    Driver cargado (solo output) pero aki no suena na

    &#191;Y si edito el AppleHDA de la 10.4.3 y borro el Azalalia?
    &#191;Tengo que borrar el ac97?

    Todo un mar de dudas invaden mi ser!!!!!!

    A ver si me exas una manita que llevo peleandome monton de tiempo!!!!!(la verda es que me mola :p )

    Gracias de antemano juker (y quien lo sepa!!!

  9. #9
    senhez Progreso Nivel 1 OSx86 Spain Karma y autoridad senhez Karma y autoridad senhez
    Avatar de senhez

    Estimado periskop,

    Lea sus mensajes privados y seguidamente realice esto:

    - Borre AppleAzaliaAudio.kext y AppleHDA.kext de /System/Library/Extensions
    - Copie AppleHDA.kext en /System/Library/Extensions
    - Borre Extensions.kextcache y Extensions.mkext
    - Repare permisos con la utilidad de discos
    - Reinicie

  10. #10
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad periskop
    Avatar de periskop

    Cita zhense dijo:
    Estimado periskop,

    Lea sus mensajes privados y seguidamente realice esto:

    - Borre AppleAzaliaAudio.kext y AppleHDA.kext de /System/Library/Extensions
    - Copie AppleHDA.kext en /System/Library/Extensions
    - Borre Extensions.kextcache y Extensions.mkext
    - Repare permisos con la utilidad de discos
    - Reinicie
    Acabo de hacer los pasos y pasa lo siguiente:
    En el campo de sonido en Preferencias del sistema el cambio a sido:
    -Reproducir alertas y efectos con: Antes HD audio (o algo asi) y ahora LineOut(y est&#225; en 2&#186;plano)
    -En la pesta&#241;a salida: el mismo cambio anterior
    -y la novedad: detecta entrada (pero no el micro del portatil)

    El mac tiene sonido SOLO con cascos, no por los altavoces del portatil.

    Ah, el sonido no se puede controlar desde el icono de la barra de menus (solo es mute-on) pero desde el iTunes no ha problema

    SEGUIREMOS INFORMANDO!!!(y vosotros ayudando plisssss!!!!!)

  11. #11
    senhez Progreso Nivel 1 OSx86 Spain Karma y autoridad senhez Karma y autoridad senhez
    Avatar de senhez

    Hola de nuevo.

    Vuelva a leer sus mensajes privados.
    Algo hemos avanzado.

  12. #12
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad periskop
    Avatar de periskop

    Update:

    La Line-in no va ni con el micro del portatil ni conectando un micro

    Reconocimiento de voz te queremos!!!! sniff, sniff

  13. #13
    senhez Progreso Nivel 1 OSx86 Spain Karma y autoridad senhez Karma y autoridad senhez
    Avatar de senhez

    Cita periskop dijo:
    Update:

    La Line-in no va ni con el micro del portatil ni conectando un micro

    Reconocimiento de voz te queremos!!!! sniff, sniff
    ¿Y con el ultimo driver?

  14. #14
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad periskop
    Avatar de periskop

    Cita zhense dijo:
    &#191;Y con el ultimo driver?
    FELIZ A&#209;OOOOO!!!!
    Siento la tardanza pero, en fin de a&#241;o ya se sabe.........

    Bueno, a lo que vamos:

    El &#250;ltimo driver no ha aportado nada nuevo; no detecta ni input ni output, asi que mejor vamos con el anterior.

    (Gracias Zhense y &#225;nimo que ya nos acercamos mas!!!!)

  15. #15
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad yuyudj
    Avatar de yuyudj

    Driver para ALC888

    Aqui te dejo el driver que he usado, dale a personalizar y elige tu configuracion.

    YuYu DJ

    ALC888

  16. #16
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad kaixo
    Siguiendo los pasos que dice Sygfrido, he logrado despertar mi Targeta de Sonido, ALC888 de Realtec, os doy las gracias a todos por ayudar y solucionar los poblemas que os planteamos.
    Gracias. :)

Notas relacionadas que te pueden interesar

  1. Realtek alc888/1200 ati
    por requette23 en categoría Tarjetas de Audio
    Comentarios: 0
    Último comentario: 01/05/09, 16:28:17
  2. Audio 5.1 ALC888 realtek mac os
    por kerdoc en categoría Tarjetas de Audio
    Comentarios: 9
    Último comentario: 18/02/09, 04:42:58
  3. Problemas con alc888 Asrock Conroe1333 osx86
    por yeyo en categoría Tarjetas de Audio
    Comentarios: 10
    Último comentario: 14/02/09, 00:32:38
  4. Realtek alc888 7.1
    por gsedano en categoría Tarjetas de Audio
    Comentarios: 3
    Último comentario: 22/03/07, 09:04:44
  5. sonido alc888 de realtek
    por ragul en categoría Tarjetas de Audio
    Comentarios: 5
    Último comentario: 26/01/07, 11:01:53