Buenas!! antes que nada quiero decir que gracias a este foro pude instalar Leopard sin ningún problema.
Ahora bien, tengo la versión de Kalyway 10.5.2 con kernel vanilla y efi boot v8 y la verdad que va bien. Sin embargo, me gustaría actualizarlo. Hace poco conseguí el comboupdate 10.5.3 y actualicé, en principio, sin problemas. Luego de revisar todo, me di cuenta que mi tarjeta de video ya no tenía soporte para Quartz Extreme ni Core Image, y por lo tanto no podía tener acceso a juegos y hasta el protector de pantalla andaba lento.
Mi placa de Video es una Asus Nvidia GeForce 6200 de 256MB, con turbocaché hasta 512MB, este problema sólo pude solucionarlo instalando de nuevo la versión 10.5.2.

La verdad que quisiera poder actualizarlo, y saber cómo solucionar el problema desde la actualización. Desde ya, muchas gracias!