kld_load_from_memory() failed for module NVDAResman.kext [solucionado]

patton

New member
Cuando entro desde el boot con la opción:

boot: -v -f

Me aparece:
kld_load_from_memory() failed for module /System/Library/Extensions/NVDAResman.kext/Contents/MacOS/NVDAResman
driver nvidia? como lo soluciono?

# nano /System/Library/Extensions/NVDANV10Hal.kext/Contents/Info.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple Computer//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dt$
<plist version="1.0">
<dict>
<key>CFBundleDevelopmentRegion</key>
<string>English</string>
<key>CFBundleExecutable</key>
<string>NVDANV10Hal</string>
<key>CFBundleGetInfoString</key>
<string>NVDANV10Hal 1.4.26.11 (7.5.0f8)</string>
<key>CFBundleIdentifier</key>
<string>com.apple.nvidia.nv10hal</string>
<key>CFBundleInfoDictionaryVersion</key>
<string>6.0</string>
<key>CFBundleName</key>
<string>NVIDIA NV10 Resman Kernel Extension</string>
<key>CFBundlePackageType</key>
<string>KEXT</string>
<key>CFBundleShortVersionString</key>
<string>1.4.26</string>
<key>CFBundleSignature</key>
<string>????</string>
<key>CFBundleVersion</key>
<string>4.2.6</string>
<key>IOKitPersonalities</key>
<dict>
<key>NVidiaRM</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.nvidia.nv10hal</string>
<key>IOClass</key>
<string>NVDANV10HAL</string>
<key>IOMatchCategory</key>
<string>IOService</string>
<key>IOPCIMatch</key>
<string>0x011010de&0xfff8ffff 0x017010de&0xfff8ffff 0x018010de&0xfff8fff$
<key>IOProbeScore</key>
<integer>60000</integer>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
</dict>
</dict>
</dict>
<key>OSBundleCompatibleVersion</key>
<string>1.2.0</string>
<key>OSBundleLibraries</key>
<dict>
<key>com.apple.NVDAResman</key>
<string>1.2.0</string>
<key>com.apple.iokit.IOPCIFamily</key>
<string>1.0.0b1</string>
<key>com.apple.kernel.iokit</key>
<string>6.0</string>
</dict>
<key>OSBundleRequired</key>
<string>Safe Boot</string>
</dict>
NVIDIA_NV11.DEV_0110.1 = "NVIDIA GeForce2 MX/MX 400"
 

patton

New member
Al instalar Natit_Uni_1.0.pkg.zip me aparece kernel panic y si booteo con -v -f me aparece.

device -id:0x0110
Natit: Found Device
Natit: Found Device Name
Natit: Setting @1, EDID=<data not shown>
Natit: Setting @0, EDID=<data not shown>
Setting device_type=NVDA, Parent
Setting @1,device_type=display
Setting @0,EID=<data not shown>
Setting @0,compatible=NVDA, NVMAC
Setting @0,fboffset=0x00020000
Setting @1,compatible=NVDA, NVMAC
Setting @1, name=NVDA, Display -B
Setting @0, name=NVDA, Display -A
NVCA=<data not shown>
Setting @0, device_type=display
model=nVidia GeForce2 MX/MX 400
NVDA::start display <1>
<1> failed






:DD
 

patton

New member
# nano Desktop/NVDriverBeta1/NVidiaHAL.kext/Contents/Info.plist
<key>IOPCIMatch</key>
<string>0x00f910de&0xffffffff</string>
<string>0x011010de&0xffffffff</string>
# cp -rf /System/Library/Extensions/NVDANV10Hal.kext /Users/patton/backup/.
# cp -rf /System/Library/Extensions/NVDANV20Hal.kext /Users/patton/backup/.
# cp -rf /System/Library/Extensions/NVDANV30Hal.kext /Users/patton/backup/.
# cp -rf /System/Library/Extensions/NVDANV40Hal.kext /Users/patton/backup/.
# cp -rf /System/Library/Extensions/NVDAResman.kext /Users/patton/backup/.
# cp -rf /System/Library/Extensions/GeForce.kext /Users/patton/backup/.

# rm -rf /System/Library/Extensions/NVDANV10Hal.kext
# rm -rf /System/Library/Extensions/NVDANV20Hal.kext
# rm -rf /System/Library/Extensions/NVDANV30Hal.kext
# rm -rf /System/Library/Extensions/NVDANV40Hal.kext

# cd /Users/patton/Desktop/NVDriverBeta1/
# cp -rf GeForceGA.plugin /System/Library/Extensions/.
# cp -rf NVDriver.kext /System/Library/Extensions/.
# cp -rf NVidia.kext /System/Library/Extensions/.
# cp -rf NVidiaHAL.kext /System/Library/Extensions/.

# chmod -R 755 /System/Library/Extensions/NVidiaHAL.kext
# chmod -R 755 /System/Library/Extensions/NVidia.kext
# chmod -R 755 /System/Library/Extensions/NVDriver.kext
# chmod -R 755 /System/Library/Extensions/GeForceGA.plugin

# diskutil repairPermissions /

# rm -rf /System/Library/Extensions.kextcache
# kextcache -k /System/Library/Extensions

# cd /Library/Preferences/
# rm -rf com.apple.windowserver
# rm -rf com.apple.preferences.display

# cd /Users/patton/Library/Preferences/
# rm -rf com.apple.windowserve
# rm -rf com.apple.preferences.display

# cd /Library/Preferences/ByHost
# rm -rf com.apple.windowserver
# rm -rf com.apple.preferences.display

# cd /Library/Preferences/SystemConfiguration/
y sacamos:
# nano com.apple.Boot.plist
<key>Boot Graphics</key>
<string>Yes</string>

y booteamos con -v

y lo unico que logre fue que cambiara el maquillaje:

# kextload /System/Library/Extensions/NVDriver.kext
kextload: extension /System/Library/Extensions/NVDriver.kext is already loaded
# kextload /System/Library/Extensions/NVidiaHAL.kext
kextload: extension /System/Library/Extensions/NVidiaHAL.kext is already loaded
# kextload /System/Library/Extensions/Nvidia.kext
kextload: extension /System/Library/Extensions/Nvidia.kext is already loaded

Y si entro con -v

Me aparece:
kextd[37]: kld_load_from-memory() failed for module /System/Library/Extensions/NVDANV10HAL.kext/Contents/MacOS/NVDANV10HAL/
kextd[37]: a link load error ocurred for kernel extension
 

senhez

senhez
Miembro del equipo
Al instalar Natit_Uni_1.0.pkg.zip me aparece kernel panic y si booteo con -v -f me aparece.
acá tienen mi misma tarjeta y parece que si les funciona, ayudaaaaaaaaaaaaaaaaaa!!!


Hola amigo

Acerca de su problema, los requisitos de natit: kernel 8.8.1 y soporte SSE3
 
Arriba