Página 1 de 2 12 ÚltimoÚltimo
  1. #1
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    Activar GPU Ati Radeon 5000 Series Sony Vaio en macOS Sierra

    Buenas tardes.
    Despues de la ayuda recibida en el apartado macos sierra de hackintosh me paso por aqui para pediros ayuda.
    Tengo un procesador i3-350m 2,26ghz con graficos ATi Radeon.
    Es la primera vez que instalo hackintosh y lo que busco creo que son los kext "drivers" del procesador y de la grafica.
    El modelo es un sopny vaio VPCEC2MIE del año 2006 aprox
    Adjunto fotos
    attachment.php?attachmentid=7396&d=1488205947
    attachment.php?attachmentid=7397&d=1488205947
    attachment.php?attachmentid=7399&d=1488207387
    Un saludo y gracias de antemano a todos


  2. #2
    Hola, te dejo tres kext que dan soporte a las ATI Radeon Series 5000, y según veo en tu perfil, he añadido tu ID 0x68C11002
    Recuerda reparar permisos con Kext Utility


    Saludos


    https://www.osx86spain.com/descargas/5-ati/148-ati-radeon-5000-series-macos-sierra.html

  3. #3
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    Cita patotropical dijo: Ver Mensaje
    Hola, te dejo tres kext que dan soporte a las ATI Radeon Series 5000, y según veo en tu perfil, he añadido tu ID 0x68C11002
    Recuerda reparar permisos con Kext Utility


    Saludos


    https://www.osx86spain.com/descargas...os-sierra.html
    Gracias, podrias decirme como instalarlo? Me e descargado el kext utility pero es la primera vez que instalo esto.

  4. #4
    Como norma general todos los kext si tienes Clover se ponen en EFI->Clover -> Kext-> carpeta del sistema operativo en cuestión o other

    A veces directamente s/l/e pero Apple si las ve las pueda excluir

  5. #5
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    Cita patotropical dijo: Ver Mensaje
    Como norma general todos los kext si tienes Clover se ponen en EFI->Clover -> Kext-> carpeta del sistema operativo en cuestión o other

    A veces directamente s/l/e pero Apple si las ve las pueda excluir
    Si tengo clover instalado pero no lo veo dentro del Macintosh HDD

  6. #6
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita
    Avatar de Bebita

    Hola, está en una partición oculta sin montar. Si tienes Clover configurator, arranca esa app y le das a montar EFI

    Antes de instalar kext te recomiendo probar con Fake ID en tu config.plist por si eganchas el kext nativo.

    En config.plist busca esta cadena

    <key>FakeID</key>
    <dict>
    <key>ATI</key>
    <string>0x68c11002</string>
    <key>IMEI</key>
    <string>0x0</string>
    <key>IntelGFX</key>
    <string>0x0</string>
    <key>LAN</key>
    <string>0x0</string>
    <key>NVidia</key>
    <string>0x0</string>
    <key>SATA</key>
    <string>0x0</string>
    <key>WIFI</key>
    <string>0x0</string>
    <key>XHCI</key>
    <string>0x0</string>
    </dict>

    Y añades tu el id




    Cita IKERTX0 dijo: Ver Mensaje
    Si tengo clover instalado pero no lo veo dentro del Macintosh HDD

  7. #7
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    Cita Bebita dijo: Ver Mensaje
    Hola, está en una partición oculta sin montar. Si tienes Clover configurator, arranca esa app y le das a montar EFI

    Antes de instalar kext te recomiendo probar con Fake ID en tu config.plist por si eganchas el kext nativo.

    En config.plist busca esta cadena

    <key>FakeID</key>
    <dict>
    <key>ATI</key>
    <string>0x68c11002</string>
    <key>IMEI</key>
    <string>0x0</string>
    <key>IntelGFX</key>
    <string>0x0</string>
    <key>LAN</key>
    <string>0x0</string>
    <key>NVidia</key>
    <string>0x0</string>
    <key>SATA</key>
    <string>0x0</string>
    <key>WIFI</key>
    <string>0x0</string>
    <key>XHCI</key>
    <string>0x0</string>
    </dict>

    Y añades tu el id
    no entiendo mucho yo de esto, pero de lo que me pones no sale todo eso solo dos lineas.
    Aqui esta el archivo config.plist
    attachment.php?attachmentid=7403&d=1488211542

  8. #8
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita
    Avatar de Bebita

    Veo que inyectas la plataforma Intel, ¿Tu vaio tiene dos tarjetas? La Intel HD integrada del procesador y la ATI dedicada?

    También para saber más, exactamente que ATI Mobility es, ¿la ATI 5400? Es que ahora mismo de cabeza no recuerdo por ese ID

  9. #9
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    Cita Bebita dijo: Ver Mensaje
    Veo que inyectas la plataforma Intel, ¿Tu vaio tiene dos tarjetas? La Intel HD integrada del procesador y la ATI dedicada?

    También para saber más, exactamente que ATI Mobility es, ¿la ATI 5400? Es que ahora mismo de cabeza no recuerdo por ese ID
    solo tengo ati no tengo intel, donde miro el modelo exacto?

  10. #10
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita
    Avatar de Bebita

    Bueno, eso es algo que tú seguro que recordaras de ver los drivers en el administrador de dispositivos Windows en otro tiempo.

    Cita IKERTX0 dijo: Ver Mensaje
    solo tengo ati no tengo intel, donde miro el modelo exacto?

  11. #11
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    Cita Bebita dijo: Ver Mensaje
    Bueno, eso es algo que tú seguro que recordaras de ver los drivers en el administrador de dispositivos Windows en otro tiempo.
    la 5470 puede ser?

  12. #12
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita
    Avatar de Bebita

    Te dejo uno muy básico a ver que pasa:


    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>ACPI</key>
    <dict>
    <key>DSDT</key>
    <dict>
    <key>Debug</key>
    <false/>
    <key>DropOEM_DSM</key>
    <dict>
    <key>ATI</key>
    <true/>
    <key>Firewire</key>
    <false/>
    <key>HDA</key>
    <false/>
    <key>HDMI</key>
    <false/>
    <key>IDE</key>
    <false/>
    <key>IntelGFX</key>
    <false/>
    <key>LAN</key>
    <false/>
    <key>LPC</key>
    <false/>
    <key>NVidia</key>
    <false/>
    <key>SATA</key>
    <false/>
    <key>SmBUS</key>
    <false/>
    <key>USB</key>
    <false/>
    <key>WIFI</key>
    <false/>
    </dict>
    <key>ReuseFFFF</key>
    <false/>
    </dict>
    <key>SSDT</key>
    <dict>
    <key>DropOem</key>
    <false/>
    <key>Generate</key>
    <dict>
    <key>CStates</key>
    <false/>
    <key>PStates</key>
    <false/>
    </dict>
    </dict>
    </dict>
    <key>Boot</key>
    <dict>
    <key>Debug</key>
    <false/>
    <key>Secure</key>
    <false/>
    <key>Timeout</key>
    <integer>5</integer>
    <key>XMPDetection</key>
    <string>Yes</string>
    </dict>
    <key>CPU</key>
    <dict>
    <key>UseARTFrequency</key>
    <false/>
    </dict>
    <key>Devices</key>
    <dict>
    <key>FakeID</key>
    <dict>
    <key>ATI</key>
    <string>0x68c11002</string>
    </dict>
    <key>USB</key>
    <dict>
    <key>FixOwnership</key>
    <false/>
    <key>Inject</key>
    <false/>
    </dict>
    </dict>
    <key>GUI</key>
    <dict>
    <key>Mouse</key>
    <dict>
    <key>DoubleClick</key>
    <integer>500</integer>
    <key>Enabled</key>
    <false/>
    <key>Mirror</key>
    <false/>
    <key>Speed</key>
    <integer>8</integer>
    </dict>
    <key>Scan</key>
    <true/>
    </dict>
    <key>Graphics</key>
    <dict>
    <key>Inject</key>
    <dict>
    <key>ATI</key>
    <true/>
    <key>Intel</key>
    <false/>
    <key>NVidia</key>
    <false/>
    </dict>
    <key>InjectEDID</key>
    <true/>
    <key>NvidiaSingle</key>
    <false/>
    </dict>
    <key>KernelAndKextPatches</key>
    <dict>
    <key>AppleRTC</key>
    <true/>
    <key>AsusAICPUPM</key>
    <true/>
    <key>KernelPm</key>
    <true/>
    <key>KextsToPatch</key>
    <array>
    <dict>
    <key>Comment</key>
    <string>iconos naranjas</string>
    <key>Find</key>
    <data>
    RXh0ZXJuYWw=
    </data>
    <key>Name</key>
    <string>AppleAHCIPort</string>
    <key>Replace</key>
    <data>
    SW50ZXJuYWw=
    </data>
    </dict>
    </array>
    </dict>
    <key>RtVariables</key>
    <dict>
    <key>BooterConfig</key>
    <string>0x28</string>
    <key>CsrActiveConfig</key>
    <string>0x67</string>
    <key>MountEFI</key>
    <true/>
    </dict>
    <key>SMBIOS</key>
    <dict>
    <key>BiosReleaseDate</key>
    <string>04/22/11</string>
    <key>BiosVendor</key>
    <string>Apple Inc.</string>
    <key>BiosVersion</key>
    <string>MBP81.88Z.0047.B0E.1104221557</string>
    <key>Board-ID</key>
    <string>Mac-94245B3640C91C81</string>
    <key>BoardManufacturer</key>
    <string>Apple Inc.</string>
    <key>BoardType</key>
    <integer>10</integer>
    <key>ChassisAssetTag</key>
    <string>MacBook-Aluminum</string>
    <key>ChassisManufacturer</key>
    <string>Apple Inc.</string>
    <key>ChassisType</key>
    <string>0x08</string>
    <key>Family</key>
    <string>MacBook Pro</string>
    <key>LocationInChassis</key>
    <string>Part Component</string>
    <key>Manufacturer</key>
    <string>Apple Inc.</string>
    <key>Mobile</key>
    <true/>
    <key>ProductName</key>
    <string>MacBookPro8,1</string>
    <key>SerialNumber</key>
    <string>C02JPDPEDH2G</string>
    <key>Trust</key>
    <false/>
    <key>Version</key>
    <string>1.0</string>
    </dict>
    </dict>
    </plist>




    Borra la caché antes de reiniciar por si no te arranca

  13. #13
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    Cita Bebita dijo: Ver Mensaje
    Te dejo uno muy básico a ver que pasa:
    por arte de magia aparece esto :)
    attachment.php?attachmentid=7404&d=1488214724
    Encima ahora me arranca ya sin el usb
    Muchas gracias, ahora solo me falta esto
    Kext sony vaio macos sierra



  14. #14
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita
    Avatar de Bebita

    ¡Caramba! Me alegra un montón ver esa imagen, ya sabes exactamente que GPU tienes, no es arte de magia, es cuestión de ID que yo no recordaba que era la 5650

    Haces grandes avances en pocas horas, yo tardé más de tres años en dominar un poco esto.

    Si agregas tu DSDT lo mismo lo podemos mejorar, si no me traiciona la memoria, las Series 5000 utilizan el Frame Buffer Eulemur y podíamos hacer algo.

    Una cosa, ¿ahora puedes al menos cambiar las resoluciones de pantalla?

    Saludines

  15. #15
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    Cita Bebita dijo: Ver Mensaje
    ¡Caramba! Me alegra un montón ver esa imagen, ya sabes exactamente que GPU tienes, no es arte de magia, es cuestión de ID que yo no recordaba que era la 5650

    Haces grandes avances en pocas horas, yo tardé más de tres años en dominar un poco esto.

    Si agregas tu DSDT lo mismo lo podemos mejorar, si no me traiciona la memoria, las Series 5000 utilizan el Frame Buffer Eulemur y podíamos hacer algo.

    Una cosa, ¿ahora puedes al menos cambiar las resoluciones de pantalla?

    Saludines
    Que es el bsdt y como lo agrego y a donde?
    veo un problema pone que tengo una pantalla de 17,8" cuando es de 17"
    adjunto foto
    attachment.php?attachmentid=7405&d=1488218624
    attachment.php?attachmentid=7406&d=1488218624

  16. #16
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    mi prima que tiene el mismo portatil que yo me a dicho que drivers lleva y es la ATI 5470
    attachment.php?attachmentid=7407&d=1488219967

  17. #17
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    Problemas:
    1.Instalado graficos ati radeon hd 5650, realmente es ati radeon 5470
    2. En Acerca de este mac/pantallas aparece que es una pantalla de 17,8 pulgadas cuando en realidad es una pantalla de 17 pulgadas
    3. Instalado una aplicacion por probar, telegram, y cuando la abro parpadea la aplicacion no la pantalla, no se si tendra que ser por algo de la resolucion o por algo del wifi
    4. cuando abro safari, y paso el raton por la barra de direciones se pixela todo por donde pasa el raton

    Un saludo y gracias :)

  18. #18
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    He encontrado esto para ATI Radeon HD5470 512mb que es lo que tiene mi grafica pero no se como ponerlo en mi hackintosh

    . insanelymac .com/forum/topic/305516-ati-radeon-5470-mobility-on-mavericks/

  19. #19
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita
    Avatar de Bebita

    Hola, los compis de macinsano hablan de agregar al config que te escribí más arriba en la sección <key>Graphics</key>




    <key>FBName</key>
    <string>Langur</string>
    <key>LoadVBios</key>
    <true/>




    O dicho de otra forma, indicarle a Clover el Frame Buffer e inyectar la Vbios


    Prueba a ver que pasa

  20. #20
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    Cita Bebita dijo: Ver Mensaje
    Hola, los compis de macinsano hablan de agregar al config que te escribí más arriba en la sección <key>Graphics</key>




    <key>FBName</key>
    <string>Langur</string>
    <key>LoadVBios</key>
    <true/>




    O dicho de otra forma, indicarle a Clover el Frame Buffer e inyectar la Vbios


    Prueba a ver que pasa
    solo añadir eso? y con eso ya detecta la grafica 5470 y los 512mb ?

  21. #21
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    lo he puesto y no pasa nada sigue todo igual

  22. #22
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita Karma y autoridad Bebita
    Avatar de Bebita

    Y además tienes los kext instalados que te ha puesto Patotropical?

  23. #23
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    Cita Bebita dijo: Ver Mensaje
    Y además tienes los kext instalados que te ha puesto Patotropical?
    si estan instalados

  24. #24
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad maxim Karma y autoridad maxim Karma y autoridad maxim Karma y autoridad maxim Karma y autoridad maxim Karma y autoridad maxim
    Avatar de maxim

    Eché un vistazo a este config.plist y creo que falta un montón de cosas. De entrada ahí no hay DSDT ni SSDT y sin eso en los portátiles no puedes aplicar los fixes que necesitan.

    La verdad es hay un montón de cosas por hacer aquí que no es solo la GPU

    Veamos, comienza cuando arranques con Clover, no inicies el sistema y presiona la tecla F4
    Así extraes el DSDT que estará en el volumen oculto EFI-Clover-APCI-Oring

    Lo copias a la carpeta patched y lo indicas así:

    <key>DSDT</key>
    <dict>
    <key>Debug</key>
    <false/>
    <key>DropOEM_DSM</key>
    <false/>
    <key>Name</key>
    <string>DSDT.aml</string>

    Despues te tienes que pillar la app SwitchResX, puedes usar la versión free o la tienes completa en Applesana.

    Con eso extraes el EDID de tu pantalla y lo pones en config.plist tal así

    <key>Inject</key>
    <dict>
    <key>ATI</key>
    <true/>
    <key>CustomEDID</key>
    <data>
    Los datos extraidos con la app
    </data>

    Y luego te queda parchear los conectores, pero creo que con esto puedes comenzar.
    La verdad es que si tuviera en mis manos ese Vaio me iba a divertir un montón y me lo comía con papas fritas. Y no el aburrido de mi firma que el jodio se instala solo. Me tiene aburrido

    Saludos

  25. #25
    OSx86 VIP donante applesanaProgreso en OSx86 Spain Nivel 0 Karma y autoridad IKERTX0
    Avatar de IKERTX0

    Cita maxim dijo: Ver Mensaje
    Eché un vistazo a este config.plist y creo que falta un montón de cosas. De entrada ahí no hay DSDT ni SSDT y sin eso en los portátiles no puedes aplicar los fixes que necesitan.

    La verdad es hay un montón de cosas por hacer aquí que no es solo la GPU

    Veamos, comienza cuando arranques con Clover, no inicies el sistema y presiona la tecla F4
    Así extraes el DSDT que estará en el volumen oculto EFI-Clover-APCI-Oring

    Lo copias a la carpeta patched y lo indicas así:

    <key>DSDT</key>
    <dict>
    <key>Debug</key>
    <false/>
    <key>DropOEM_DSM</key>
    <false/>
    <key>Name</key>
    <string>DSDT.aml</string>

    Despues te tienes que pillar la app SwitchResX, puedes usar la versión free o la tienes completa en Applesana.

    Con eso extraes el EDID de tu pantalla y lo pones en config.plist tal así

    <key>Inject</key>
    <dict>
    <key>ATI</key>
    <true/>
    <key>CustomEDID</key>
    <data>
    Los datos extraidos con la app
    </data>

    Y luego te queda parchear los conectores, pero creo que con esto puedes comenzar.
    La verdad es que si tuviera en mis manos ese Vaio me iba a divertir un montón y me lo comía con papas fritas. Y no el aburrido de mi firma que el jodio se instala solo. Me tiene aburrido

    Saludos
    Que de Vitoria a Burgos hay una hora en coche jaja lo mismo me tengo que pasar.
    buff vere que soy capaz de hacer con todo eso que me has puesto
    Un saludo

Página 1 de 2 12 ÚltimoÚltimo

Notas relacionadas que te pueden interesar

  1. kext de audio sony vaio macos sierra
    por IKERTX0 en categoría Tarjetas de Audio
    Comentarios: 3
    Último comentario: 01/03/17, 01:20:37
  2. kext Atheros AR9285 sony vaio macos sierra
    por IKERTX0 en categoría Tarjetas de Red
    Comentarios: 7
    Último comentario: 28/02/17, 01:20:01
  3. kext sony vaio macos sierra
    por IKERTX0 en categoría HackinBook
    Comentarios: 0
    Último comentario: 27/02/17, 16:04:55
  4. macOS Sierra 10.12.2
    por maxim en categoría OSx86 10.12 macOS Sierra
    Comentarios: 6
    Último comentario: 01/12/16, 13:19:07
  5. Tarjetas WI-FI compatibles con macOS Sierra
    por nemetal en categoría Tarjetas de Red
    Comentarios: 1
    Último comentario: 09/11/16, 11:46:30

Etiquetas en este tema

No te pierdas:

ati 5000 sierra

driver para mac de la ati serie hd 5000