1. #1
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad RodrigoV2.0

    Core Image y Quarz Extreme ATI Radeon X550

    hola a todos, utilizo 10.4.5 funciona todo, solo q no va Core image y Quartz Extreme.... utilizo la placa ATI Radeon X550 ...
    alguien sabe como arreglar este problema...

    gracias de antemano


  2. #2
    Activo Progreso en OSx86 Spain Nivel 0 Karma y autoridad erJotas
    creo que si, solamente tienes que editar hexadecimalmente el dirver de la 9700. En los foros de explican como.


    Saludos.

  3. #3
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Pero no sé si vas a conseguir QuartzExtreme y CoreImage, además es posible que no te deje usar resoluciones mayores a 1024x768.

  4. #4
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad Videl
    Avatar de Videl

    Como haceis para cambiar la resolución? Me se el truco de editar el com.apple.Boot.plist, pero la pega es que una vez dentro solo me sale esa resolucion. Un consejo, no os instaleis ni locos el DisplayManager, os reventará el tiger y solo podreis solucionarlo reinstalando... :?

  5. #5
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    Re: ATI x550

    Cita RodrigoV2.0 dijo:
    hola a todos, utilizo 10.4.5 funciona todo, solo q no va Core image y Quartz Extreme.... utilizo la placa ATI Radeon X550 ...
    alguien sabe como arreglar este problema...

    gracias de antemano
    Intenta editar el driver como dice aqui, a ver si tienes suerte

  6. #6
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad Bloodangel
    Avatar de Bloodangel

    Ati X550 mac

    Holas a todos miren como agradeceria que me dieran la forma o los drivers si existen para hacer funcionar una ATI x550 PCI-E lo que pasa es que me compre para otra de mis mauinas esa tarjeta y sin percatarme compre la de la marca POWERCOLOR y no la de SAPHIRE asi que no me da el QE y el CI menos el open gl asi que como le ago plissss haaa y muchas gracias a los que me ayudaron con lo de mi tarjeta de sonido la sigmatel GRACIAS MIL me funciona re genial lo raro es que solo sale audio de la clabija de audio out y no de la de spk out jejej ya ni modo pero funciona eso es lo que cuenta ok gracias ahora quiero q me ayuden en esta ok vale nos vemos
    :F

    Laurana...

  7. #7
    pelujo
    Internet

    Ati Radeon X550

    Hola a todos...

    Ya se que se ha hablado en otros hilos de esta tarjeta, pero lo que he encontrado es algo que no me aclara mucho la situacio. Asi que explico el problema que tengo y los pasos que he dado.

    Bien tengo en mi equipo una grafica en PCIe, una Ati X550, he rebuscado en muchos foros y el caso es que afirman que esta tarjeta es capaz de funcionar QE/CI perfectamente, pero yo despues de proba imnumerables veces distintas configuraciones, no he conseguido activar esto.

    He probado los koverg-patch9700-v0.2.tgz, siguiendo el readme al pie de la letra.

    Resultado, ningun cambio.

    Tanto cambiando IONDRVFramebuffer a CallistoFB, como dejandolo como esta.

    He probado con los callisto la version 3 y 8, instalandolos como viene en el readme.

    Resultado, ningun cambio.

    Despues encontre los ATIScript.z0rz.v0.2.zip, siguiendo al pie de la letra las instrucciones.

    He probado estas configuraciones.

    sudo ./doe.sh cal3 0x0x0 0 0 Ningun cambio
    sudo ./doe.sh cal3 0x0x0 1 0 Ningun cambio
    sudo ./doe.sh cal3 0x0x0 1 1 Ningun cambio
    sudo ./doe.sh cal5 0x0x0 0 0 Ningun cambio
    sudo ./doe.sh cal5 0x0x0 1 0 Ningun cambio
    sudo ./doe.sh cal5 0x0x0 1 1 Ningun cambio
    sudo ./doe.sh cal6 0x0x0 0 0 Ningun cambio
    sudo ./doe.sh cal6 0x0x0 1 0 Reconoce por primera vez la tarjeta como X550
    sudo ./doe.sh cal6 0x0x0 1 1 Reconoce la tarjeta como X550
    sudo ./doe.sh cal8 0x0x0 0 0 Reconoce la tarjeta como X550
    sudo ./doe.sh cal8 0x0x0 1 0 Reconoce la tarjeta y reconoce el tipo de monitor como C551
    sudo ./doe.sh cal8 0x0x0 1 1 Reconoce la tarjeta y reconoce el tipo de monitor como C551

    Pero con ninguna de estas configuraciones consigo la activacion del QE/CI.

    Asi que esto es lo que tengo ahora mismo.



    Radeon X550 (PCIE):

    Modelo de chipset: Radeon X550 (PCIE)
    Tipo: Pantalla
    Bus: PCIe
    VRAM (total): 256 MB
    Fabricante: ATI (0x1002)
    ID del dispositivo: 0x5b63
    ID de la revisión: 0x0000
    Pantallas:
    C551:
    Resolución: 1024 x 768 @ 60 Hz
    Profundidad: Color de 32 bits
    Core Image: Incompatible
    Pantalla principal:
    Duplicado: Desactivado
    En línea:
    Quartz Extreme: Incompatible

    No se si servira de algo, perocomo informacion adicional la ISO instalada que tengo es la Jas 10.4.8 Intel&AMD SSE2,SSE3 Semtexth 8.1.1.

    Si hay alguien que lo tenga que por favor expique como lo ha conseguido, si es necesario explicare los paso que he dado uno a uno, a ver en que estoy metiendo la pata.

    Un saludo, y gracias.

  8. #8
    pelujo
    Internet
    Hola a todos de nuevo.....

    Sigo con la busqueda de activacion de QE/CI para la X550, y rebuscando, leyendo, y editando archivos, he llegado a la siguiente conclusion.

    Para poder activar QE/CI se utiliza Coverg, pero en el hilo que tiene Koverg en Forum, indica que es para utilizar en versiones 10.4.3 a 10.4.6

    Asi que despues de tanto probar, resulta que si tengo instalado 10.4.8 no funciona.

    El problema esta en que el archivo Ati9700.kext que tiene la ISO 10.4.8 es diferente al que utilizan las otras ISOS, ya que he editado el archivo y he rebuscado por todos lados el texto a modificar, 3D 5B 60 00 00, el cual se ha de sustituir por 3D xx xx 00 00, (donde xx xx es el identificador de nuestra tarjeta), y resulta que esta linea o texto no aparece por ningun lado.

    De hecho cuando realizo el parche, cuando termina de instalarlo, este indica "0 Matches", con lo que en realidad quiere decir que no hay coincidencias y no se ha aplicado el parche.

    Asi que ahora tengo una duda. Si cambio el Kext que tengo ahora mismo, que pertenece a la 10.4.8, por el Kext de una ISO 10.4.6, (que es la ultima version comentada en el foro), Funcionaria? o daria algun problema?

    Gracias y espero vuestras respuestas, mientras tanto estoy en busca de este kext, suelto, para no tener que descargar ninguna ISO.

  9. #9
    senhez Progreso Nivel 1 OSx86 Spain Karma y autoridad senhez Karma y autoridad senhez
    Avatar de senhez

    Hola amigo

    Vaya al foro Guias de Hardware encontrara soluciones que otros usuarios escribieron.
    La chincheta Como instalar ATI Radeon 9700 en OS X mediante patch le puede ayudar.
    Tambien puede probar este paquete de drivers
    Archivos Adjuntos Archivos Adjuntos

  10. #10
    pelujo
    Internet
    Senhez, gracias por interesarte, pero he de decirte que resulta que esta fue la primera guia que vi, y segui al pie de la letra, pero no va. O al menos a mi no, y en dos equipos diferentes.

    Tambien decirte que como he dicho antes, cuando el Pacth se ejecuta, este indica que no ha encontrado coincidencias, "0 matchets". Esto creo que indica que no se ha instalado el parche.

    Abrimos el koverg con un editor de texto....:

    ATIKEXT=/System/Library/Extensions/ATIRadeon9700.kext << Indica la ruta donde esta el Kext>>

    BACKUP=$HOME/Documents/originals <<Indica la ruta donde hacer el Backup>>

    HI=$1 <<Indica el valor alto de nuestro ID>>

    Lo=$2 <<Indica el valor bajo de nuestro ID>>

    echo Patching to device id: 0x$HI$LO <<Linea explicativa>>

    mkdir $BACKUP <<ir al directorio indicado en BACKUP>>

    cp -R $ATIKEXT $BACKUP <<Copia el contenido del Kext a la ruta de Backup>>

    ./binmay -v -i $BACKUP/ATIRadeon9700.kext/Contents/MacOS/ATIRadeon9700 -s "3d 60 5b 00 00" -r "3d $LO $HI 00 00" -o $ATIKEXT/Contents/MacOS/ATIRadeon9700


    << En esta ultima linea, se esta indicando que se ejecute el programa "Binmay", con los modificadores "-v -i" en el directorio que se indica.
    Despues tenemos el modificador "-s" de Search (Buscar) y se indica el texto "3d 60 5b 00 00"
    Despues tenemos el modificador "-r" de replace (Reemplazar) y se indica que se reemplace por "3d $LO $HI 00 00", donde ya se indico antes que $LO $HI es el valor de nuestro ID.

    Despues tenemos el modificador "-o" el cual he de reconocer que no se que significa, pero por deduccion indica que se guarden los cambios en el directorio seleccionado.

    (Si me he equivocado en algo, corregidme por favor)

    Despues de esta explicacion, de como funciona el parche de Koverg, y viendo que al aplicarlo no hace ningun efecto sobre el sistema, me descargue un editor HEX para Mac, y edite el archivo AtiRadeon9700, que se encuentra en el directorio /System/Library/Extensions/ATIRadeon9700.kext/Contents/MacOS/ que es el que modifica el Parche de Koverg.

    Una vez editado, busco por todos lados la linea o lineas a modificar, y no aparece ninguna cadena ni en binario ni en hexagecimal que coincida.

    Asi que el parche no se puede aplicar sobre este archivo.

    De ahi que este buscando el archivo de una version, comprendida entre la 10.4.3 y la 10.4.6, que al parecer son las que funcionan con el parche de Koverg.

  11. #11
    Kyller
    Internet

    Core Image y Quarz Extreme en X550

    Hola,

    Quisiera ayuda sobre la instalacion o configuracion de la extension para la ATI x550.
    He siguido los pasos de mucho posts y no consigo activar CI ni QE.
    Lo habia hecho antes con la version 10.4.5 pero ahora he instalado la vesion 10.4.9 de uphuck v1.3, sin instalar ningun Calisto ni ningun driver de ATI y no consigo activar la aceleracion.
    He bajado el parche de Koverg, lo he ejecutado dandole los deviceID, despues he editado el archivo de extension ATIRadeon9700.kext y he modificado los ID's como dicen en el post "Como Instalar ATI Radeon 9700 en OS X mediante patch".
    Despues he seguido los pasos uno a uno hasta ya reparar permisos y reiniciar.
    Pero nada no se activa la aceleracion.
    Tambien he intentado cargar la extension con kextload pero me da un error: kid(): Undefined symbols: _proc_pid
    Mi sistema
    Pentium 4 3.02MHz HT SSE3
    chipset i915
    2 Gb RAM
    ATI X550 PCIe
    200Gb SATA
    230Gb ATA

    Si alguien supiese lo que puede pasar y quisiera ayudarme se lo agradeceria.

  12. #12
    senhez Progreso Nivel 1 OSx86 Spain Karma y autoridad senhez Karma y autoridad senhez
    Avatar de senhez

    Justo detrás de este último mensaje suyo hay uno mio que adjunta un paquete de drivers. Pruebelo y comente resultados.

    Si le funciona correctamente en Mac OS X 10.4.9 por favor edite el Wiki y hágalo saber al resto de usuarios/as que también tengan esa tarjeta.

  13. #13
    Kyller
    Internet
    Hola

    He descargado los drivers q adjuntaba en el anterior post, los he instalado y sigue igual sin haber aceleración.

    Despues de buscar en varios sitios y leer unos cuantos mensajes creo q lo q me hace falta es el archivo ATIRaderon9700.kext de la version 10.4.5 o menor, pero no consigo encontrarlo.
    Si alguien pudiera ponerlo para descargar se lo agradeceria, haber si damos con el clavo de una vez, y para todos.

  14. #14
    Kyller
    Internet
    Bueno he conseguido extraer los drivers de la version 10.4.5 con Pacifist, y el resultado a sido q ahora si me carga el kext "ATIRadeon9700.kext" pero sigo con Core Image y Quarz Extrme Incompatible.
    Lo mas raro es que al intentar usar algo que le hace falta aceleración el monitor se apaga y tengo que resetear manual porque no veo nada.
    No se si alguien sabe lo que he hecho mal.
    El kext q he extraido lo he editado como siempre y le he puesto mi ID donde habia el 5B60, despues lo he copiado a la carpeta Extensions, y despues he reparado permisos y he reiniciado.
    No se si he hecho algo mal.

  15. #15
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad macmusic

    Ayuda para ATI X300/550

    Hola:

    Bueno, después de un fin de problemas ha conseguido poner en marcha mi OSX86 sobre una mobo ASus M2V.

    El tema es la activación del Core y Quartz sobre esta tarjeta. He leído un montón de instalaciones que hay en los foros para activar estos componentes pero nada. lo más lejos que he llegado ha sido ver, cuando arrancaba el SO, como los Callisto me detectaban mi tarjeta pero la REV. 380 y no la REV. 370 que es la mía. He probado a cambiar la Id en el Atiradeon9700 y CallistoHal, en estas me aparecía la 5B63 y yo tengo la 5B60. Pero nada.

    Alguien tiene esta tarjeta con este ID y como lo ha conseguido, si se puede?

    ATI X300/550 Series (Rev. 370). PCI-Ex.
    ID 5b60
    128 Vram


    Gracias a todos.

  16. #16
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad uglyman
    obrigado por ajudar com esse driver

  17. #17
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad abarra98

    Core Image y Quarz Extreme ATI Radeon X550

    Estimados:
    Alguien ha logrado activar estas opciones con una x550 en Leopard, si tienen algun metodo por favor compartan, yo solo he logrado activar diferentes resoluciones.

    Saludos
    abarra

  18. #18
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad pedripe
    Pues si, he logrado activar el QE para esta gráfica.
    Procedimiento: Instalé el driver para la x550 que senhez posteó más arriba, con el driver en cuestión ya podemos cambiar la resolución y queda activado por software el CI, pero QE sigue sin funcionar. Entonces instalé las X86 Tools le di al botón de activar QE y después de reiniciar, voilá QE activado y funcionando.

    Tengo instalada la distro Ideneb 10.5.4 v1_1

  19. #19
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad pedripe
    Pues si, he logrado activar el QE para esta gráfica.
    Procedimiento: Instalé el driver para la x550 que senhez posteó más arriba, con el driver en cuestión ya podemos cambiar la resolución y queda activado por software el CI, pero QE sigue sin funcionar. Entonces instalé las X86 Tools le di al botón de activar QE y después de reiniciar, sigue sin estar activo, pero se activa el Quartz GL
    Tengo instalada la distro Ideneb 10.5.4 v1_1

  20. #20
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad pedripe
    Disculpas por el doble post, QE no se ha activado, pero si el QUartz GL

  21. #21
    Tímido Progreso en OSx86 Spain Nivel 0 Karma y autoridad arielus

    Disculpa la ignorancia

    Hola!!!!!..... perdòn soy nuevo aquí.... quisiera saber qué es eso de las X86 Tools y dónde las encuentro?????....... necesito saber con urgencia por favor....Gracias!!!

Notas relacionadas que te pueden interesar

  1. Cómo activar Quartz Extreme y Core Image ati radeon hd4500
    por dlanos en categoría Tarjetas Gráficas
    Comentarios: 47
    Último comentario: 13/05/15, 11:56:53
  2. GMA900 Mac OS X Leopard con Core Image y Quartz Extreme
    por juker12 en categoría Tarjetas Gráficas
    Comentarios: 32
    Último comentario: 17/10/09, 03:31:30
  3. Comentarios: 0
    Último comentario: 02/09/09, 17:22:40
  4. Activar Core Image y Quartz Extreme Ati x1300
    por Bloodangel en categoría Tarjetas Gráficas
    Comentarios: 35
    Último comentario: 29/08/08, 01:10:01
  5. Sin Core image & Quartz Extreme despues de actualizar 10.4.10
    por jsbetancourt en categoría Tarjetas Gráficas
    Comentarios: 0
    Último comentario: 30/11/07, 21:32:12