Página 1 de 2 12 ÚltimoÚltimo
  1. #1
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    ATI Sapphire x1650 Pro en Tiger / Leopard con QE y CI (MacLovin)

    MacLovin tiene una guía, en forum.osx86scene.com, sobre cómo instalar las tarjetas gráficas de la serie ATI x1600 en Leopard, con el título:

    "[Guide] ATI x1x00 Video Cards on Leopard; QE/CI Enabled"

    En mi caso he probado a instalar una tarjeta ATI x1650 Pro con 256 MB de RAM, de la marca Sapphire en Tiger 10.4.11 y ha funcionado, consiguiendo aceleración gráfica y un buen funcionamiento, sin artefactos.

    Como la guía de MacLovin está en inglés y es un poco larga, la resumo en base a mi experiencia personal por si a alguien con esta tarjeta o similar le pudiera servir. Aunque las instrucciones están muy detalladas, no es una guía para principiantes, se da por sentado que el usuario sabe activar root, editar extensiones, arrancar Darwin con modificadores -v (verbose) y -f (forzar la carga de extensiones), averiguar el ID de la tarjeta gráfica, etc.

    Archivos necesarios

    - ATIinject.kext (en la guía de MacLovin hay un enlace al archivo)

    - ATIRadeonX1000.kext original (copiado de la carpeta Extensions o del DVD de Tiger)

    Programas necesarios

    - editor de archivos Info.plist (TextMate de Allan Odgaard, Propertylist Editor de XCode Tools de Apple, Textedit de OSX también funciona con muchos archivos plist, no con todos)

    - 0xED de SuaveTech- editor hexadecimal

    Paso 1: editar ATIinject.kext - Info.plist



    - botón derecho sobre ATIinject.kext >> Mostrar contenido del paquete

    - Contents >> Info.plist (abrir este archivo)

    - buscar la sección que define el DeviceID de la tarjeta gráfica (en este ejemplo sería 71c1):

    <key>ATY,DeviceID</key>
    <integer>0x71c1</integer>

    - las secciones comentadas a continuación pueden ser borradas:

    <key>ATY,FrameBufferOffset</key>
    <integer>0x00000080</integer>

    <key>ATY,IOSpaceOffset</key>
    <integer>0x00300000</integer>

    <key>ATY,VRAM,MemSize</key>
    <integer>0x00000100</integer>

    - guardar el archivo y salir

    Paso 2: editar ATIRadeonX1000 - Info.plist

    - botón derecho sobre ATIRadeonX1000.kext >> Mostrar contenido del paquete

    - Contents >> Info.plist (abrir este archivo)

    - buscar la sección <key>IOPCIMatch</key> para añadir el DeviceID de la tarjeta gráfica, procurando conservar las entradas que ya existan y evitando duplicados (provocarían kernel panic al arrancar), añadiendo la nueva en el mismo formato que las otras; por ejemplo, con DeviceID 71c1 y VendorID 1002 (corresponde a ATI) la sección quedaría similar a ésta:

    <key>IOPCIMatch</key>
    <string>0x71871002 0x71c11002 0x71c31002 0x72101002 0x71DE1002 0x71461002 0x71421002 0x71091002 0x71C51002 0x72401002 0x72491002 0x72911002</string>

    - guardar el archivo y salir

    Paso 3: editar con 0xED el archivo binario ATIRadeonX1000

    - este paso siempre ha de ir detrás del paso 2, si se modifica el archivo Info.plist de nuevo después de la modificación binaria con 0xED el PC no arrancaría por lo que la última modificación en ATIRadeonX1000.kext ha de ser la hexadecimal

    - arrancar el programa 0xED >> File >> Open >> ATIRadeonX1000.kext >> Contents >> MacOS >> ATIRadeonX1000

    - menú Edit >> Find >> Find

    - buscar c071 para reemplazarlo por el DeviceID de la tarjeta gráfica pero invirtiendo las parejas, si el ID es 71c1 el reemplazo sería c171; se configura la búsqueda como "Search type=Hex" >> Replace all (en mi caso sólo se encontró 1 coincidencia pero en otros sistemas ese número puede variar)

    - buscar 71c0 para reemplazarlo por el DeviceID de la tarjeta gráfica tal cual, si el ID es 71c1 el reemplazo sería 71c1; se configura la búsqueda como "Search type=Hex" >> Replace all (en mi caso se encontraron 3 coincidencias pero en otros sistemas ese número puede variar)

    - menú File >> Save >> Exit

    Paso 4: instalar archivos, limpiar cachés, reparar permisos y reiniciar

    - borrar en System/Library/Caches la carpeta com.apple.kernelcaches

    - borrar en System/Library los archivos Extensions.mkext y Extensions.kextcache

    - borrar en System/Library/Extensions el archivo ATIRadeonx1000.kext (o renombrarlo a ATIRadeonx1000.kext.back) y cualquier archivo relacionado con la terjeta gráfica que se hubiese instalado anteriormente

    - copiar los archivos modificados ATIinject.kext y ATIRadeonX1000.kext a System/Library/Extensions

    - reparar permisos

    - reiniciar >> pulsar F8 para que aparezca el menú de Darwin >> arrancar con -v -f

  2. #2
    SUPERTUTORIALLLLLL!!!!!!!!!!
    Milliuco es para felicitarte, gracias.
    Pero estoy pensando en pillar esta Sapphire pro 256Mb (la del enlace) y me gustaría que pudieras (tu o cualquier otro applesano crac) explicar la edición del kext ATIRadeonX2000.kext y todo el proceso en definitiva para las ati 2000. Aunque si lega el glorioso dia en que se me termine de bajar el kalyway 10.5.1 creo q hay cierta "posibilidad" de que funcionen unas cuantas tarjetas con él (mirad la imagen).

    Gracias Milliuco xDD

    2.jpg


    VGA PCIE ATI HD 2600PRO 256MB SAPPHIRE

    Fabricante Chip: ATI
    Chip Grafico: Radeon HD 2600PRO
    Memoria RAM: 256MB DDR2
    PCI Express: x16
    Interface de memoria: 128 bits
    Nucleo grafico (Core): 600 MHz
    Reloj de memoria: 800MHz
    Pipelines: 4
    DirectX: 10
    Pixel Shader: 4.0
    Conectores: DVI X2 / S-Video / Adaptador DVI a HDMI
    Ventilador: si

  3. #3
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    No he hecho nada con tarjetas como la que comentas, busca primero a ver si hay algo por ahí para tener más seguro que la puedas usar en OSx86. El que sea como las que llevan algunos Mac no lo garantiza, busca información.

  4. #4
    Ya lo he hecho, y creo q si funcionará, hasta que no lo pruebe no quiero decir nada más...por si acaso xD
    Pero ya lo he decidido, me la voy a pillar con una placa base Asus Commando o P5K-E/wifi-AP

    Asus Commando:
    P5K-E/wifi-AP:

    jejejeje, q ganas tenia

  5. #5
    Ah, y a ver como van con 10.5.1 y EFI, el kalyway se me acabara de bajar +/- mañana por la tarde!!
    Ya contare en el hilo EFI

  6. #6
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Son 2 placas excelentes, veo más probabilidades en la Commando, el audio parece Azalia, ¿no?, pero ¿y la red?

    Echa un vistazo a ésta:



    Socket 775 (C2D...)
    Chipset Intel G965
    SATA Chip Intel ICH8 Southbridge
    Graphics Media Accelerator X3000
    Sonido ADI 1988A
    Realtek Gigabit Ethernet
    etc...

  7. #7
    senhez Progreso Nivel 1 OSx86 Spain Karma y autoridad senhez Karma y autoridad senhez
    Avatar de senhez

    Hola amigo Miliuco

    Este paquete de drivers hace exactamente eso

    Drivers Series X1X Ati X1650 Pro PCiExpress 256MB

    Sólo para Leopard e ID 71c1

  8. #8
    Milliuco, sobre la placa, esta bien pero, yo lo que busco era una con chipset para Penryn, que si te pasas por la pagina de Apple veras el nuevo Mac Pro Penryn 8 cores Xeon de serie con 12Mb L2 y 1600Mhz FSB y por lo que no quedan dudas sobre incompatibilidades Mac-P35/X38-Penryn.
    Mañana recojo la Asus P5K-E/wifi-ap, la grafica Sapphire 2600Pro 256Mb (el nuevo mac pro lleva la 2600xt) y 2 gb Ram DDR2 800Mhz kingston (a la velocidad de la Ram del nuevo Mac Pro) aunque creo q me acabare comprando unos modulos q he visto a 1066 Extreme Memory por 35€.
    Por cierto en el hackintosh actual (el de la firma) ya tengo kalyway 10,5,1 EFIv8 i va absolutamente perfecto, me reconoció perfectamente el Audio Realtek, Red PCI Realtek, la GMA950 QE/CI,... el único problema es que en acerca de este mac dice que mis 2 modulos 1gb 667Mhz van a 333Mhz, alguien sabe xq puede pasar esto??

    Gracias y pasaros por Apple, pues se han lucido bastante con el nuevo Mac Pro
    3.jpg

  9. #9
    Estoy teniendo problemas con mi nueva placa P5K-E y la grafica Sapphire HD2600pro 256mb, al instalar el sistema no arranca ni en AHCI ni IDE estando la particion marcada activa, siendo una particion sola en el disco y solo ese disco conectado, y la grafica no tiene QE/CI con los drivers de Apple, los que hay en el wiki para Tiger solo me han ocasionado un panic.
    Alguien puede pasar drivers para esta grafica por favor??
    Estoy pensando en cambiar la placa por la comando y la grafica por una nVidia 7300gt point of view 512mb o una Ati x1600. Que opinais?
    Necesito ayuda urgente

  10. #10
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Zhense: tengo guardado ese instalador de ATI 71c1 por si acaso más adelante pruebo Leopard, lo descargué desde la página en que MacLovin tiene sus instrucciones:

    forum.osx86scene.com >> "[Guide] ATI x1x00 Video Cards on Leopard; QE/CI Enabled"

    Tiene otros instaladores para otros DeviceID, todos son para Leopard, por éso en mi tutorial, que es para Tiger, recurro al método manual aunque en realidad lo que propongo en él equivale a lo que MacLovin prepara en su instalador por lo que supongo que funcionaría también en Tiger.

  11. #11
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Godisnotalive: piensa en lo que traen los Mac, salvo algunos Mac Pro los demás usan gráficas de 256 MB de memoria, en caso de comprar una Geforce 7300GT, cógela de 256 MB para asegurar la compatibilidad.

    En la sección de Hardware >> Tarjetas NVidia tengo un tema sobre una GeForce 7300GT de 256 MB de la marca Asus (modelo EN7300GT) y en él comento lo fácilmente que se instala con los drivers NVinject, sin tener que modificar kext ni escribir DeviceID, funcionando con QE + CI + resoluciones + rotación (pero no he conseguido la salida de doble monitor).

  12. #12
    La placa P5K-E y la XFX 7300gt de 512mb que me compre se llevan como el culo. Estoy pensando en pillar la gigabyte que Juker puso en el wiki , que esta en APP por 90€ con una gigabyte x1650 o quedarme con mi 7300gt i continuar calentandome la cabeza. Que pensais?

  13. #13
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    La propuesta de Juker parece de lo más atractiva.

  14. #14
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    godisnotalive de perdido al rio

    Mira estaba yo por comprarme ya mismo la grafica de Miliuco en split por 100 euros las dos graficas

    La Nvidia 7300 completamente compatible con Mac OS X Tiger y Leopard

    Pero pense, mejor pillate la ATI Radeon HD 2600 XT de los nuevos Mac PRo e iMac 2007

    Y hoy me tiro al rio, ni una cosa ni la otra, me pillo el mes que viene la Nvidia 8800

    https://www.applesana.com/blog/kit-a...-polemica.html

    que va divina de muerte con los Kexts oficiales de Mac OS X 10.5.2 nativos, de 64 Bits como a mi me gusta y sin tocar por nadie

    Esa grafica 8800 y lo que tengo ahora, un cohete nuclear

    Comprar mi placa por la grafica no lo recomiendo, he tenido la developer con una GMA900 y es muy limitada.

    La que trae mi placa de ahora es la GMA x3100 que no es la misma que la de los portatiles y he sudado tinta china para instalarla en un solo monitor.


    Ademas, como integrada que es, pilla solo 64MB muy limitado, asi que lo dicho...grafica externa una 8800 nativa.

  15. #15
    Juker pasate por aqui (https://www.osx86spain.com/14/7646/g...g33m-ds2r.html) y dime que te parece esta placa es muy parecida a la tuya(red, audio, controladora de discos,..). Ok?
    Oye cuando dices que las 8800 pillan bien los drivers de 10.5.2 te refieres a los del wiki? Cuando pruebes la grafica molaria que hicieras un post. Yo cuando consiga que la mia tenga QE/CI hare uno, parece un caso dificil...uff xD

  16. #16
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    godisnotalive ya he probado esa grafica ( la Nvidia 8800 ) y alguna mas en mi equipo y va divina de la muerte

    Pero las he devuelto junto a las placas base.
    No me gusta tener algo que aun no he pagado por muy amigo que sea el OEM.

    Y si, con los kext oficiales que hay en el wiki applesana que vienen de Mac OS X 10.5.2.
    Lo unico que tienen esos kext es que estan empaquetados.

  17. #17
    has visto la placa? Basicamente es como la tuya solo que lleva 2 PCI Express 2.0 y chipset X38 sin grafica integrada, me mola bastante la placa.
    Has probado alguna similar con kalyway, vanilla kernel y efi?

  18. #18
    y esta graficas? Es un modelo que me gusta particularmente

  19. #19
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    Miliuco yo no he seguido tu tutorial ni tampoco los drivers del wiki

    Lo hecho a mi modo y veo los 512MB y core image y quart extreme activado pero......

    Solo en Mac OS X 10.5.1 por que en la actualizacion 10.5.2 mas actualizacion de graficos 1.0 no puedo...de momento

    Parece que la actualizacion de graficos tiene mas chica de lo que yo pensaba.
    Con esta ultima actualizacion la muy joia da casi 75 puntos mas en OpenGL pero pillo sombras negras

    asi que a investigar

    Bueno...pues sigo pelando que soy mas torpe que todo
    Miniatura de Adjuntos Imágenes del artículo  

  20. #20
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    ¿Ya llegó, Juker? No la llegué a probar en Leopard pero en Tiger iba muy bien, sin artefactos. Como a ti te gusta hacerlo por ti mismo, supongo que no pararás hasta que encuentres la manera de que vaya OK. Pero si deseas probar algo sencillo, en el hilo en que se habla del método MacLovin en el foro pitinglis, cuyo título es
    "[Guide] ATI x1x00 Video Cards on Leopard; QE/CI Enabled"
    se puede descargar un instalador ya preparado para varios ID de esta tarjeta, creo recordar que era 71c1 (también lo veo ahora en la imagen que has posteado) , descarga ése y a ver si funciona.

    Yo, por si acaso, no he puesto la actualización de gráficos (es la única actualización que tengo sin instalar) porque me convenció tu argumento de para qué tipo de Mac estaba diseñada sobre todo, la verdad es que con Natit cogido del canal #RadeonHD en el IRC de Netkas va perfecta, mejor que con Triakis (no sé por qué pues son drivers muy parecidos).

    Todavía no tengo la 8800GT 512, en cuanto la pruebe lo comentaré, supogo que Leopard no la reconocerá sin más y que tendré que instalar los drivers de 10.5.2 que hay en el wiki, ¿no?.

  21. #21
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Me ha picado la curiosidad y, como tenía copia de Time Machine en disco Firewire, he instalado la actualización de gráficos para Leopard, todo ha ido bien y he pasado XBench de nuevo y el resultado total del test es casi el mismo y los de cada tipo de test en particular son muy parecidos:

    Sin la actualización de gráficos:

    Results [COLOR="blue"]186.16[/COLOR]

    Xbench Version 1.3
    System Version 10.5.2 (9C31)
    Model MacPro3,1

    CPU Test 150.81
    Thread Test 234.37
    Memory Test 193.07
    Quartz Graphics Test 237.66
    OpenGL Graphics Test 189.86
    User Interface Test 376.41
    Disk Test 60.18

    Con la actualización de gráficos:

    Results [COLOR="blue"]188.55[/COLOR]

    Xbench Version 1.3
    System Version 10.5.2 (9C31)
    Model MacPro3,1

    CPU Test 151.71
    Thread Test 234.17
    Memory Test 198.04
    Quartz Graphics Test 236.30
    OpenGL Graphics Test 188.63
    User Interface Test 377.85
    Disk Test 51.33

  22. #22
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    Puñetas que envidia. Pues yo con los nuevos ATI de la actualizacion de graficos pillo 70 mas en opengl y 40 en quart pero me salen sombras negras.

    (antes de la actualizacion de graficos 1.0 borro todos kext ati, para estar seguro que cargo con lo nuevos)

    Sin la actualizacion no tengo cojones de hacer andar la grafica en 10.5.2 pelao, ni maclovin, ni drivers wiki ni puñetas al sol

    Con maclovin y su invento solo pillo 256MB en mac 10.5.1, en mac osx 10.5.2 un precioso kernel panic ( creo que el invento de maclovin anda desfasado )


    Con los oficiales y cambiando el boot de arranque que es como lo tengo ahora pilla sus 512MB y va francamente bien, pero eso si, solo en mac os x 10.5.1

    El caso es que gracias a ti otra vez tengo la ilusion del cacharreo, no te imaginas lo distraido que estoy je je

    corto y cambio.....seguire informando

  23. #23
    Activo Progreso Nivel 1 OSx86 Spain Karma y autoridad miliuco
    Avatar de miliuco

    Pero, Juker, que esa tarjeta sólo tiene 256 Mb de memoria, en Tiger siempre se mostraba con esa cantidad de Ram.

    ¿Has probado a cambiar el conector del monitor entre los 2 DVI? La recomendación es que se debe usar el que está más cercano a la placa base, que en teoría sería el nº 1 pero ¿has probado?

    Creo que tendrás que usar el método miliuco (je, je, en realidad solo es MacLovin traducido), si te decides a probarlo, éstos son los archivos que necesitarás:
    Miniatura de Adjuntos Imágenes del artículo  
    Archivos Adjuntos Archivos Adjuntos

  24. #24
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    ummmm, voy a probar tus kext

    Me tiene ya un poquillo despistado. Con la actualizacion 10.5.2 + graficos 1.0 lo mas que he llegado:

    Todo perfecto sin sombras ni rastros pero la barra superior tan tan transparente que apenas se ve ni las letras de menus ni el logo de Apple.

    En otra configuracion:

    Todo perfecto en transparencias pero justo en el logo un cuadro negro. Lastima que ya no tenga la camara para mostrarte el boot -v

    Y ver como efi me inyecta un canal pci-express asignado a la grafica reconociendo placa DS-G33 gigabyte.


    Si tus kext no funcionan me tomare unos dias de descanso (llevo 12 instalaciones, jeje vicioso que soy)

    Y me planteare volcar la rom del imac ( eso si..cuando no me vea nadie por casa, por que como me pillen con el imac otra vez patas arriba me la van a liar ja ja)


    Se entiende que en Mac OS X 10.5.1 todo bien pero muy muy puntualmente sale un cuadrito en el puntero del raton. Nada del otro mundo.

    Pero mi reto es dejarlo perfecto en 10.5.2 con graficos 1.0 y a ser posible inyectado en la rom de inicio.

  25. #25
    Activo Progreso OSx86 Spain Nivel 3 Karma y autoridad juker12 Karma y autoridad juker12
    Avatar de juker12

    Bueno termine por fin

    Mac OS X 10.5.2, drivers oficiales inyectado en boot asignado un canal pci-express

    Sin ratros, quart perfecto, cambio de resoluciones y solo un slot, no dual pantalla
    Divino de la muerte

    Esta comprobado que la actualizacion de graficos 1.0 tiene mas chicha de la que imaginaba
    A parte de sustituir los kext Ati, gforce y de mas.... cambia alguna libreria mas en el sistema

    Tengo dos particiones gemelas con 10.5.2
    En una perfecto y en la otra instale la actualizacion de graficos y se ha quedado inservible aunque sustituya kext.


    Ummm, tendre que jugar al "juego de las 7 diferencias"

    Lo que mas me mosquea es que tu instalaste graficos 1.0 y no tienes mejoras

    ¿Ganas de dar por saco de Apple? Curioso que a tu no te afecte con una 2600

    Seguire investigando el fin de semana si no salimos.

    Por cierto, pena me da del lio de kext y versiones que hay para instalar las ati x1 por internet
    La mitad de esos paquetes son una porqueria.

Página 1 de 2 12 ÚltimoÚltimo

Notas relacionadas que te pueden interesar

  1. Ayuda para conseguir QE + CI ati x1650 en snow leopard
    por nomaste en categoría Tarjetas Gráficas
    Comentarios: 1
    Último comentario: 23/07/10, 18:25:48
  2. ATI Sapphire x1600pro 512Mb AGP
    por bbyp en categoría Tarjetas Gráficas
    Comentarios: 0
    Último comentario: 31/07/08, 17:02:57
  3. Problema ati x1650 pro ID71c7 Leopard
    por germanboy en categoría Tarjetas Gráficas
    Comentarios: 1
    Último comentario: 15/07/08, 23:27:58
  4. ATI X1650 XT en Leopard
    por cirbic en categoría Tarjetas Gráficas
    Comentarios: 2
    Último comentario: 13/02/08, 10:18:25
  5. ATI X1650 XT
    por Bloodangel en categoría Tarjetas Gráficas
    Comentarios: 14
    Último comentario: 13/02/08, 00:32:23

Etiquetas en este tema